MOD: STA2 Upgrade Project 2014 - A stock A2 mod in FO

I want my 15 rapid-fire quantum torpedo launchers Uber-Defiant now! - Get help from modders. Share your work. Discuss modifications.
1 ... 23, 24, 25, 26, 27
posted on December 10th, 2017, 12:13 am
Hey guys tried running this game I can start and play it fine then it crashes and get an error saying its run out of memory,
I would like to know how thats possible with 32gb ram
posted on December 13th, 2017, 5:35 pm
Sorry to hear of your issue. Can you play Fleet Ops without any issue and it's just the mod that gives the out of memory error?

I thought I read that Doca stated somewhere that running in compatibility mode doesn't really do anything with FO, but have you tried that at least?
posted on December 14th, 2017, 1:08 am
I have tried running in compatibility mode and no go still still keeps crashing
posted on December 14th, 2017, 4:05 am
Out of Memory Errors have nothing to do with your computer's available memory at all. It has to do with the game alone and it's ODF files. Some ODF file is missing a " somewhere within it.

This is from the FleetOps Guide, namely the Bug/Crash Checklist page:

"Out of Memory Error" anywhere along the load-screen progress bar
Likely causes:

A quotation mark was missed before or after something in an ODF.

Here is the link to that page:
http://guide.fleetops.net/guide/modding/tutorials/bug-crash-checklist
posted on December 14th, 2017, 4:58 am
So does regular Fleet Operations work just fine with no errors? I'm sorry, but I'm not much help I guess. A while back when a few others we having issues I downloaded the files everyone else was downloading and the game played just fine with all races. I run Win 7 64bit.

I estimate less than 5% of those who downloaded this have issues so unless the download corrupted I don't believe a " is missing from an ODF file.

Have you tried playing the exact same races again on the same map and does the error repeat reliably?
posted on December 14th, 2017, 8:31 am
Fleet operations runs fine without a hitch, its just the upgrade project that has the issues, on all races 1 player or 8 and different settings sometimes i can get longer game play than others but happens every game
posted on December 14th, 2017, 12:49 pm
If it isn't a missing " then it's you've overtaxed your computer on memory. I stated the missing " because a few times I've had that occur way after a game has loaded; normally with weapon files.

There is another thing though and it's why I don't play FleetOps anymore and only use mods I trust or have taken apart FleetOps in the 4.0 version loader and replaced it with different mods and added a Mods Directory to be based on that mod. The game still calls it FleetOps but normally it's Star Trek Armada II Mods based on the stock game or Star Wars mods. This problem I'm getting at that can overtax a computer's memory is: Textures and high poly models; both of which FleetOps proper is flooded with and my 6gb of RAM laptop hates it, it starts lagging with so much models in play and the game eventually crashes if I don't manually close it... sometimes having to use Task Manager.

Here's evidence to this in the FleetOps Guide:

Levels of detail (LOD) allow Armada to display a different texture for the same model depending on how far in / out the player is above the particular model. This allows the artist to control the resolution of the texture being used at each height and to remove unnecessary detail when zoomed out. In turn - and most importantly - this impacts the performance of the game. Large textures (or large numbers of textures) quickly use up available memory, and Fleet Operations can only use 3gb of RAM before a Memory Allocation error will occur and crash the game. It is thus highly recommended to use levels of detail whenever possible to reduce the chance of this happening. Jumping from a 64x64 to a 128x128 pixel texture will only double the resolution, while in turn quadrupling the memory used to display the texture.

http://guide.fleetops.net/guide/modding/visuals-effects/models-textures

I'm not sure if the stock version of Armada II uses the same 3gb of RAM like FleetOps does before a Memory Allocation Error but I'm guessing the answer is yes since it's now commonly a mod within FleetOps. Either way it doesn't matter if your computer has 6gb of RAM or 32gb of RAM, in the end FleetOps is only allowed to use 3gb of that RAM; which can of course cause problems with high textures, high poly count models in high intensity games with more than two players especially when taking into account how long the game has progressed.
posted on December 14th, 2017, 10:50 pm
In saying that then, regardless will always get this error when playing any of this, is there away to fix this
posted on December 16th, 2017, 4:05 am
I'm only guessing here with this answer but I'd have to go out on a limb and say that it's most likely hardcoded like that so that it's impossible to be fixed. Given how it says it's programmed to use 3gb of Memory (RAM).
posted on December 16th, 2017, 4:45 am
Just to point out the scope of work when I made the mod, almost every texture in the game was changed with higher resolution textures and every ship/station model as well. Almost every ship/station has phong lighting to react to ambient light from nebulas, latinum nebulas, dilithium moons, and weapon sprites. I dialed down the background light as well to more show all these light effects.

I think the ships/stations in FO are higher poly, but you generally field less amounts of them compared to A2. So in the mod that's a lot of graphics the game has to process.

I wish I could help more, but a few people just seem to have issues running it. My computer is nothing fancy from 2009. I run Win7 64bit, 5gb ram and a gtx460, but thankfully beyond the occasional miscellaneous crash in game I don't seem to suffer any issues.

I really want rebuild the mod from scratch again including a stock version, but just haven't gotten around to it. Maybe some day
posted on December 16th, 2017, 2:39 pm
rifraf wrote:Just to point out the scope of work when I made the mod, almost every texture in the game was changed with higher resolution textures and every ship/station model as well. Almost every ship/station has phong lighting to react to ambient light from nebulas, latinum nebulas, dilithium moons, and weapon sprites. I dialed down the background light as well to more show all these light effects.

I think the ships/stations in FO are higher poly, but you generally field less amounts of them compared to A2. So in the mod that's a lot of graphics the game has to process.

I wish I could help more, but a few people just seem to have issues running it. My computer is nothing fancy from 2009. I run Win7 64bit, 5gb ram and a gtx460, but thankfully beyond the occasional miscellaneous crash in game I don't seem to suffer any issues.

I really want rebuild the mod from scratch again including a stock version, but just haven't gotten around to it. Maybe some day


I haven't personally had any problems with your mom either rifraf, of course I only play against the AI with it playing as 1 or 2 opponents. Plus I have a strategy that I think helps with preventing such an error. The strategy didn't work with FleetOps proper though and I did end up with major lags but no "Out of Memory" crash; of course the lag was getting to me so I also ended the game each time that happens.
posted on December 18th, 2017, 9:59 pm
Yeah I think it might be due to me having 6-7 other opponents as well, when i get a chance will try with 1 or 2 and see if I get the same error, so I dare do say its not the mod itself just the background programming from armada itself with he mod attached to throw errors in some cases
posted on December 19th, 2017, 5:56 am
I've found this with KA2 as well. 1 vs 1 or even 2 vs 2 works fine no matter what combination of races. A large map with 8 or so opponents fairly rapidly crashes the game. It's nothing i've been able to fix sadly
posted on December 19th, 2017, 9:25 am
Hey yeah I can play 1v1 perfect and 2v2 but after that it crashes
posted on December 19th, 2017, 5:52 pm
I'm not sure if this was asked, but have you played the stock A2 Classic mod? If so does it give you any issues at all? I thought I'd ask as it is basically stock with just enough to get it to work as a mod in FO. It may be worth it to try it so we can compare the two?
1 ... 23, 24, 25, 26, 27
Reply

Who is online

Users browsing this forum: Bing [Bot] and 3 guests