MOD: STA2 Upgrade Project 2014 - A stock A2 mod in FO

I want my 15 rapid-fire quantum torpedo launchers Uber-Defiant now! - Get help from modders. Share your work. Discuss modifications.
1 ... 25, 26, 27, 28, 29, 30
posted on May 9th, 2018, 12:37 am
Ok, I just installed this mod a couple weeks ago, on a FleetOps install I have been using for some time. Mod seems to work great aside from a couple annoyances.

However, I just tried to play FleetOps itself, and it crashes seconds after an instant action game starts.

Is there a fix for this, or do I just have to reinstall FleetOps without your mod?

P.S. I and my kid both really like this mod. The extra units added in are fun, even if they dont seem to have a specific place in strategy. By the way, the alternate borg seems to work fairly well in multiplayer, at least with a 10 year old.

Just want to have FleetOps too.
posted on May 9th, 2018, 3:09 pm
Last edited by yochenhsieh on May 10th, 2018, 12:25 pm, edited 1 time in total.
This mod should be installed into a subfolder called "mod" in fleetops installation and activated via mod setting in fleetops. It does not and should not affect your fleetops files.

posted on May 9th, 2018, 4:33 pm
I'm glad you like it, but as Yochenhsieh stated this mod or any mod if put in the 'mods' folder you should have created in the root directory of the Fleet Ops install shouldn't cause any issues with FO itself.
posted on May 12th, 2018, 5:25 am
I understand that, and I did have to create the mods folder as this is the first FleetOps mod I have installed. Unfortunately the fact is that FleetOps stopped working the first time I attempted using it after installing this mod. I will play around with it a little and get back with you.
posted on May 12th, 2018, 5:49 am
Ok, nevermind.

I dont know what happened last time, but I just uninstalled fleetops, after making a backup copy of the mods folder, reinstalled and put the mods folder back.

Tested 5 min on both fleetops and STA2 Upgrade Proj. No issues so far. It has at least got me past my original problem, as it was crashing 1-5 sec after launch.

Sorry for bothering you with that. I should have tried a full re-install first.

I do have a couple questions about the mod though, concerning minor bugs we have noticed:
1. Does the install download on the first page of the thread currently include all patches? If not the remainder of my questions may be moot, as that is all I have downloaded.

2. certian maps are unplayable by races other than 8472, as everything built by the original starbase gets stuck at the edge of the map. Freeing your ships requires decommisioning the starbase, and building another further from the map edge which puts that player at an extreme disadvantage.

3. The build buttons and tooltips for the two embrios for 8472 are reversed.

4. Several hotkeys for ship building are labled incorrectly, or do not work at all.

5. Very minor: Original A2 had staged research for the upgrade facilities (third research station) so only the currently buildable level of upgrade was visible on the research menu. Yours shows all three levels for each subsystem. I am not sure if this was deliberate or not but it seems a bit cluttered.

Other than that, excellent mod. As I said before both me and my son love playing it. I especially like the new model for the cardassian starbase. Considerable improvement over the original. Not sure if you made it or found it, but it looks awesome.
posted on May 14th, 2018, 2:22 am
Hi Voyager. Glad you got it working.

As to your questions: 1) the main download 2.0a is the main game with all patches I had at that time. Then I had the 2.0b patch which was the last one I made a little bit later.

2) I have never heard of what you're describing with the maps and starting bases. Is this in the campaign or just instant action maps?

3) I may have gotten the build buttons mixed up on the 8472 embryos. I will have to look at that.

4) Are the incorrect hotkeys for standard base game ships or the new ships I added? I'll have to look at that as well.

5) For the research I don't exactly recall, but I think I did that for a reason. I may be thinking incorrectly, but IIRC it was due to one research pod of level 1 would destroy and build over a research pod of level 2 so in effect you were stuck in a loop of rebuilding pods. Or perhaps it was the AI that was getting stuck. I believe that is why I did it that way

As for the mod I didn't make anything. I don't have that kind of talent. I used material from those around the community who made all the ship/stations/textures/etc.
posted on May 15th, 2018, 4:56 pm
I had skim-read this topic but couldn't find any info on the issue I have. That is the tool tip for the federation defense platform is not right. It is saying "FED_TURRET-WEAPON RANGE 900"


What are the polys for the ships for this mod, because I am thinking of adding a constitution class ship, refitted with klingon or romulan weapons, as that is in one of the novels.... the Enterprise-A having klingon/romulan disruptors... and I want the ship to look as details as the rest of the federation ships.
In other words what constitution class ship mod would be recommend for use with this mod?
posted on May 16th, 2018, 4:34 pm
Hi SFox. I don't think I changed any of the stock tooltips so I'll have to check that.

As for the ship poly's I'm not sure? Aad Moerman made them all and I think he made a pack with all the ships named Enterprise. You'll have to check the Armada downloads site that was posted on here to get them. Here's the link Doca Cola posted:
posted on May 24th, 2018, 12:29 am
Hello again Rifraf. Sorry it took me so long to reply.

2. The issue I was having was with the instant action/multiplayer maps, most notably with the Borg starbase in certain starting points. The starbase seems to be too near the edge of the map in the direction that ships come out, so the ship gets stuck between the station and the edge of the map. If additional ships are built, they get stuck in exactly the same spot, and look like only one ship. (multiple ships just coming out seem to occupy the same space where they get stuck) I do not remember the name of the maps which I identified this on, but there were two of them. I will have to test again to get you that information.

Now that I think of it this may have actually been an issue in the original game. I seem to remember the Borg not being playable on at least one map starting location for this reason.

3. The build buttons and tool-tips on the embryos are definitely backwards. Not game breaking, but irritating. Its still the 9 year olds favorite race.

4. Ships/stations both seem to have incorrect or missing hotkeys. Few if any are correct. Added ships have no hotkey in the tool-tip, so if one exists there is no way to know what it is.

5. If the upgrade facility research was deliberate, its cool. As I said slightly cluttered, but cool. Only recommendation I might have would be to rearrange the buttons in the tray so that all weapons, then all shields, then all engines, etc upgrades are listed together. Its a little cumbersome as is to go looking for the next level if you are only trying to upgrade one system for a specific tactical advantage. Examples: engines only to outrun Borg, sensors to expand range of scouts and sensor stations fighting cloak, etc.

Still a great mod. One off topic question: do you know if anyone is doing the B5 mod for A2 Stock on Fleet Ops? This would be awesome! Would require new models, some of them in the mod are pretty flat&simple but a redo would be great.
posted on June 29th, 2018, 4:18 am
Ok, sorry to spam here again, but Im having the same issue again where FO starts crashing on launch of a multiplayer or instant action game a week or so after a mod is installed. It has happened four times now, and is getting rather irritating. I am not sure if this is somehow related to this mod, or the mod management system in FO, or something else.

In addition, after the last time, a fresh install of FO no longer corrects the issue. I apologize if this is not the correct place to post this problem, but I have already posted on the known bugs thread, without reply.

Any help that anyone could provide would be appreciated, even if just to direct me to the proper thread.

Thank You
posted on June 29th, 2018, 10:04 am
I too often have this on start crashing - but it is random on other mods too Like Dominion Wars - but relaunching usually clears it. Also if I save a save and try to return it crashes, but the game does save nonetheless.

I find some crash at the start on certain maps - so just tend to avoid those maps and choose another.
I run mine on Windows 10 64 Bit an have my mod shortcuts set for XP2 Compatibility and running as admin.
Some maps (again on Dominion Wars 2 Mod) playing as the Borg are really difficult because the ships are so much bigger (especially the non-tactical cubes) and they simply will not pass around objects - especially if you have a Borg Unimatrix built - I always have to build these with enough distance apart for a large cube to get by or you just back jam everything and of course when they are trying to get to a destination, they just won't fire at anything when stuck and trying to navigate through / round an object!
I know this is a different Mod here - but I think some of these 'issues' are applicable to other mods.
So, if you can't get in to the main screen without a crash, check your mod shortcut compatibility settings and experiment, sometimes that works. But where it doesn't, I find I generally uninstall the Mod before the stress kicks in and something else gets kicked out that I usually regret later!
posted on July 3rd, 2018, 1:18 am
Thank you for your reply. Though I am not sure we are talking about the same problem.

The mod I installed in the mods folder still runs fine when launched with the mod manager built into FO.

About a week after installing a mod, its FO itself that started crashing on launch (happened two times). I tried multiple maps without a successful launch.

I am starting to wonder if perhaps an update to windows may have happened shortly after I installed the mod, which is now causing an issue.

The first two times this started happening, completely uninstalling FO, and reinstalling (with or without the mod) fixed it. However that is no longer the case. My last two reinstall attempts have failed to resolve the issue. I have reinstalled the mod in the mods folder, and it still runs fine even on the fresh, but still broken, install of FO.

I am stumped.
posted on July 3rd, 2018, 4:42 pm
I'm not sure how a mod inside FO could cause FO itself to stop working? If you're just playing FO then it's not accessing the mod folder so nothing in there should affect anything unless you're specifically playing a mod.

I wanted to address the hotkeys as well. I'm working on the stock version of the Upgrade Project and found that the missing/incorrect hotkeys are from stock. The original Devs used the same hotkey on multiple ships and some are just missing. I'm hoping to correct that and perhaps do a patch for the FO version of the Upgrade Project some time.
posted on July 10th, 2018, 3:15 pm
Doctor Rush wrote:Hi everyone!

It's been a week or so since I installed this mod, and I must say I find it very good aside for a several (minor) problems I encountered which I will try to explain here as much as possible.

1. Borg and Species 8472 AI's are messed up in skirmish, or to be more precise they don't build much (even at higher diff setings). Similar problems is with Klingons and Federation, but instead of almost not bulding any ships/station they do it, but at extremely slow pace (even at higher difficulties).

3. Single player (campaing) AI is ridiculously overpowered. During first Federation mission in about a minute or so after I have built orbital processing facility Borg has swarmed me by fleet of at least two dozen assimilators/spheres/interceptors. And like that wasn't enough they continued to do it in waves every 30 seconds or so. Yes, I want a challenge and I knew it would be harder if I set game to hard difficulty, but this seems more like a brutal difficulty to me (something that can be seen in C&C 3 Tiberium wars for example). Even the Outpost didn't helped much and it is really difficult to keep the Enterprise out of the way from so many Borg ships.

6. Colors of races are messed up. In the single players colors of races are not what they are supposed to be. For example, Romulans are purple instead of green, Klingons and Species 8472 are black, Cardassians are green, Federation is red and so on. That is very confusing and not good for a gameplay at all. Klingons and 8472 are especially problematic as they are almost impossible to notice on minimap due to the black color.

1.3. You can try the AIPs from stock A2 and see if it works better. I attached the files here.
6. This problem also exists in STA2 Classic Import. I guess it was caused by Fleetops but I'm not sure. Has any one here found a way to fix the team colors in single player campaign?

(146.8 KiB) Downloaded 263 times
posted on July 14th, 2018, 11:55 pm
Hey Rifraf,

I no longer believe that your mod is the cause of my FO issue. Especially since your mod works fine now, and even a fresh install of FO now has the crash issue.

I am hypothesizing that something changed with my system (most probably a windows update that is causing something to work differently with my home built hardware).

I have also discovered that the crash does not occur exactly on game launch. Last week I was working on this, and went to eat some of my dinner while the game loaded, then found to my astonishment that the game did not crash. That is, until I touched the mouse.

Moving the mouse causes the FO crash. I have already tried restoring the computer to before last windows update, reinstalling mouse drivers, reinstalling and upgrading GPU drivers, and another fresh install of FO, this time with a reboot after uninstall, and after reinstall.

Has anyone else had this problem: "Moving the mouse causes the FO crash."

Thank you kindly
1 ... 25, 26, 27, 28, 29, 30

Who is online

Users browsing this forum: No registered users and 1 guest