MOD: STA2 Upgrade Project 2014 - A stock A2 mod in FO

I want my 15 rapid-fire quantum torpedo launchers Uber-Defiant now! - Get help from modders. Share your work. Discuss modifications.
1 ... 20, 21, 22, 23, 24, 25, 26 ... 29
posted on March 29th, 2015, 4:55 pm
rifraf wrote:Another thing, I tried something else and got more weird results. On any map I can hit ctrl-A when it loads and it takes me into the editor. I can do whatever then go back to the game and continue with the mission with no issue. I tried it on this map though and what happened was the screen altered a bit in that the words in the map editor menu became thicker in print, the sounds changed a bit and the mouse pointer left tracks all over the map if I moved it.

In A1, the mouse leaving trails and the text seeming to get thicker was caused by a missing SOD for the map background. The engine didn't know what to do when rendering over nothing so it just kept rendering new frames and not cleaning up stuff from the old ones. A2 and FO use a pure texture skybox but it may be essentially the same issue. Do the textures used for this map's backgrounds have any transparency? Can you invoke the menu to change backgrounds on this map?
posted on March 29th, 2015, 7:36 pm
cabal wrote: In A1, the mouse leaving trails and the text seeming to get thicker was caused by a missing SOD for the map background. The engine didn't know what to do when rendering over nothing so it just kept rendering new frames and not cleaning up stuff from the old ones. A2 and FO use a pure texture skybox but it may be essentially the same issue. Do the textures used for this map's backgrounds have any transparency? Can you invoke the menu to change backgrounds on this map?

I know this question is for rifraf but i also did this with no result!

Attachments

FOScreenShot_150329_222107.png
No result!...
FOScreenShot_150329_222107.png (821.43 KiB) Viewed 684 times
FOScreenShot_150329_222348.png
No result!...
FOScreenShot_150329_222348.png (688.24 KiB) Viewed 684 times
posted on March 29th, 2015, 8:00 pm
Fleet Trek wrote:
cabal wrote: In A1, the mouse leaving trails and the text seeming to get thicker was caused by a missing SOD for the map background. The engine didn't know what to do when rendering over nothing so it just kept rendering new frames and not cleaning up stuff from the old ones. A2 and FO use a pure texture skybox but it may be essentially the same issue. Do the textures used for this map's backgrounds have any transparency? Can you invoke the menu to change backgrounds on this map?

I know this question is for rifraf but i also did this with no result!

I didn't think that was the main problem, but did it fix the map editor view?
posted on March 29th, 2015, 9:35 pm
I just don't know what is going on with this map!?...
posted on April 3rd, 2015, 1:57 am
I've tried twice now to download this mod from the links on the first page, both times Chrome blocked it as a malicious file. Anyone else getting this problem?
posted on April 3rd, 2015, 2:59 am
cabal wrote:
Fleet Trek wrote:
cabal wrote: In A1, the mouse leaving trails and the text seeming to get thicker was caused by a missing SOD for the map background. The engine didn't know what to do when rendering over nothing so it just kept rendering new frames and not cleaning up stuff from the old ones. A2 and FO use a pure texture skybox but it may be essentially the same issue. Do the textures used for this map's backgrounds have any transparency? Can you invoke the menu to change backgrounds on this map?

I know this question is for rifraf but i also did this with no result!


I didn't think that was the main problem, but did it fix the map editor view?

I haven't had the chance to check different map backgrounds yet so not sure on my end. Like you said A2 doesn't use SOD's for map backgrounds, but what do you mean about the map having transparency? I have to wonder how many versions ago with the mod this started? When I redid all the maps I had to test them to get objects and ship placement right and such and this never presented an issue.

SPARTAN078 wrote:I've tried twice now to download this mod from the links on the first page, both times Chrome blocked it as a malicious file. Anyone else getting this problem?


I tried with the latest Explorer and Firefox and had no issues?
posted on April 3rd, 2015, 5:25 am
rifraf wrote:I haven't had the chance to check different map backgrounds yet so not sure on my end. Like you said A2 doesn't use SOD's for map backgrounds, but what do you mean about the map having transparency?

I mean if the texture for the backdrop uses the alpha channel.
posted on April 11th, 2015, 3:26 pm
Hi, I`ve downloaded the mod a few days ago but when i play instant action the game is freezing after playing a few minues in instant acttion :blink: and i can`t save a mission in the single player campaigne

Hoy can i fix this?

Greetings darkhorizon
posted on April 11th, 2015, 7:00 pm
darkhorizon1905 wrote: when i play instant action the game is freezing after playing a few minues


I have the same problem!... :-\
For a long time i thought that this is caused by some maps, but then i realized that this is caused by overloading of the game engine... :ermm:

darkhorizon1905 wrote: and i can`t save a mission in the single player campaigne


To save the game press Ctrl+S :thumbsup:
posted on April 12th, 2015, 2:23 am
I have the 2013 version of the STA2 import mod and im trying to play the Federation campaign. The cargo ship menu is missing so I can't get past the second mission nor will the cheat code 'kobayashimaru' work so I can't skip it. Is there something I need to add to the odf, either of fcargo or cargo.odf? Please help.
posted on April 12th, 2015, 4:11 am
darkhorizon1905 wrote:Hi, I`ve downloaded the mod a few days ago but when i play instant action the game is freezing after playing a few minues in instant acttion :blink: and i can`t save a mission in the single player campaigne

Hoy can i fix this?

Greetings darkhorizon


Hello darkhorizon, sorry you are having issues with the mod. Do you have any issues with freezing when playing Fleet Ops without any mods? Have you changed anything in regards to the mod after you downloaded it? Could it be your computer specs (goes back to FO itself with no mods?)

@SPARTAN078: FO v3.2.7 had a bug regarding trading. From EvilGenius many posts back: "Use D, L or M to load dilithium, latinum or metal. If you just want to set up trade routes, you can just right click the first and second trading station as per normal, you should still be seeing the 'begin trade' and 'end trade' icons when you hover over a trading station with a cargo ship selected."

@Cabal: I don't think I edited any background objects only ships/stations. All the background stuff is from Midnight Universe 2.0 so not sure what Yacuzza did with those? With work being crazy busy and summer quickly approaching I've been outside much more getting the yard and house ready. I would really like to go back and start from the beginning download and find which patch made the Borg mission 10 map go all screwy
posted on April 12th, 2015, 6:19 am
Last edited by yochenhsieh on April 12th, 2015, 12:18 pm, edited 3 times in total.
Temporary fix for Borg mission 10 "Rift":
Extract and copy attached bbattle2.sod into SOD folder, overwrite existed file.

The problem is in the mesh of Tactical Cube sod. I tried re-save it again with AssimSoft editor and it seems fixed. Please report back if there's any problems.

Attachments

bbattle2.zip
(17.16 KiB) Downloaded 217 times
posted on April 12th, 2015, 7:28 am
yochenhsieh wrote:
Temporary fix for Borg mission 10 "Rift"


Might be Temporary fix, but is working!...:borg:
Thank you yochenhsieh! :thumbsup:
posted on April 12th, 2015, 10:50 am
Hi @rifraf :) No the Original Fleetops Game is running Normaly. the Original A2 too.
@Fleet Trek How can i load the previously saved game?
posted on April 12th, 2015, 11:11 am
darkhorizon1905 wrote:
@Fleet Trek How can i load the previously saved game?


Just go to load game button in the bottom right corner of the screen. :)

Attachments

load_game_button.jpg
Load game button...
load_game_button.jpg (106.12 KiB) Viewed 289 times
1 ... 20, 21, 22, 23, 24, 25, 26 ... 29
Reply

Who is online

Users browsing this forum: No registered users and 1 guest