MOD: STA2 Upgrade Project 2014 - A stock A2 mod in FO

I want my 15 rapid-fire quantum torpedo launchers Uber-Defiant now! - Get help from modders. Share your work. Discuss modifications.
1 ... 25, 26, 27, 28, 29
posted on July 15th, 2018, 11:35 pm
Ok, found a workaround for the crashing issue I was having with Stock FO.

I will make another thread about it in technical stuff for anyone who has the same issue in the future, just posting it here because this is where I started with this problem and then found out it was an independent problem.

So, long story short, if you have a problem with FO crashing when the mouse is moved after launching, go into options in FO, then graphics settings, and uncheck the box for asynchronous cursor.

This box is checked by default by install, and didnt cause me any problems until a couple months ago, but for some reason the game crashes now whenever a game is running and the mouse is moved. Unchecking the asynchronous cursor box seems to resolve the issue.

I have also noticed that I now have to run FO as an administrator, and agree to let it make changes to my computer on each launch.

This happened to me on two computers running windows 10 at roughly the same time.
posted on January 25th, 2019, 6:39 am
I've managed to fix most of the team colors in singleplayer campaign, except species8472. Please extract the teamcolor.odf from attachment and overwrite your file in odf/others/. This file works for both STA2 stock import and STA2 Upgrade mod.

Attachments

teamcolor.zip
(573 Bytes) Downloaded 80 times
posted on April 21st, 2019, 12:11 am
I have a few questions.

First of all, this is an excellent mod. I've been playing it recently and it is an appropriate update of the base game of STA2. I have not played the other STA2 update mod, but I can't imagine I would ever need to thanks to this one.

Question 1:
Is anyone aware of mods that reskin the default planet textures? Right now every Class M planet is Earth and everything Class J is Jupiter. That is a bit immersion breaking for me, and I'd prefer if the planets were either more generic, or just different.

Question 2:
The little cinematic window in the corner is broken for me. The species logo always appears overtop of the video that is playing. Is there a fix for this?

Thank you!
posted on April 23rd, 2019, 7:04 pm
Thanks for playing it, I'm glad you like it.

Q1. I used a mod that is of high resolution textures for planets, but only Earth is depicted for the M class one. There are a lot of mods available to change the planet textures at http://armadafiles.com/ that you can try.

Q2. For the cinematic window is it just when you play as Species 8472 or any race?
posted on April 25th, 2019, 10:58 pm
rifraf wrote:Thanks for playing it, I'm glad you like it.

Q1. I used a mod that is of high resolution textures for planets, but only Earth is depicted for the M class one. There are a lot of mods available to change the planet textures at http://armadafiles.com/ that you can try.

Q2. For the cinematic window is it just when you play as Species 8472 or any race?


I didn't even know that site existed, so I appreciate the link. I haven't played STA2 since about 2004.

As for the cinematic window, it only appears to be happening on the Federation. The Klingons don't seem to have the problem, and I haven't played the Borg yet.
posted on June 25th, 2019, 2:18 am
Greetings again,

I've finally made it to the Borg campaign with little issues other than the messed up Federation viewscreen (which I just ignored). However, on the first mission of the Borg, I am experiencing a crash anytime I start to gather resources with enemy ships. I'm not sure what's going on there.
posted on July 25th, 2019, 11:06 pm
I was hoping someone could help me with the sounds again. I thought I had this fixed years ago in past versions, but in getting this ready to release again I am having problems in that I can hear ships come out of warp from across the map.

Does anyone know if it's a specific setting in my audio file? This doesn't happen in stock FO just my mod inside FO. The ambient settings I have in my planets also are too high now it seems as when I can see a planet (not covered by the fog of war) it has a load ambient sound too.

I just tested and I can hear a ship come out of warp across the map in the Classic mod as well.
posted on August 1st, 2019, 10:57 pm
I have another question if anyone knows the answer. In my admirals log at the end of a game where it shows all the ships built/destroyed, points, etc. mine is blank. It doesn't show any information at all. Does anyone know what file controls what is shown?

The AdmiralsLog.odf is unchanged. Could it be a sprite or a global.cfg file?
posted on August 2nd, 2019, 3:17 am
rifraf wrote:I have another question if anyone knows the answer. In my admirals log at the end of a game where it shows all the ships built/destroyed, points, etc. mine is blank. It doesn't show any information at all. Does anyone know what file controls what is shown?

The AdmiralsLog.odf is unchanged. Could it be a sprite or a global.cfg file?


Disregard. I got it fixed. It was the teamcolor.odf file that Yochenhsieh posted above. For some reason it messes up the admirals log tally screen and prevents it from displaying any text or ship images.
posted on September 24th, 2019, 9:51 am
Hey thanks for making this. Could you possibly update the original post with links to all the patches? or a full download of the most recent version? Thanks :)
posted on September 25th, 2019, 3:13 am
You're welcome. I tried the 2.0a full download and the 2.0b patch download and they both work. Do they not work for you?
1 ... 25, 26, 27, 28, 29
Reply

Who is online

Users browsing this forum: No registered users and 3 guests