Star Trek Armada Patch 1.3 Project

Announcements and news by us. Post comments about them here.
1, 2, 3, 4, 5, 6
posted on September 17th, 2011, 11:36 pm
This is excellent news as A1 is still a really good game and it's great to see you guys are helping to keep it alive on new systems. I sure hope you develop this further to iron out any bugs that show up. I think this is needed much more than a A2 Patch Project.

You continue to surprise me and I look forward to any further additions to this project in the future.  :thumbsup:
posted on September 18th, 2011, 3:41 am
Awesomeness!

I hope this isn't the last thing you fantastic guys will do for Armada 1 as when Future Tense modification is released many will be wanting to play it again.
posted on September 18th, 2011, 3:48 am
wow i missed playing this game does the patch work to help mods of A1 work like the star trek armada alliances because that was the greatest armada mod ever other than fleetops
posted on September 18th, 2011, 6:56 am
im guessing all the great old mods for a1 will work fine with this fix, i'll look forward to playing with this today, cant wait for millennium mod again amongst others!
posted on September 18th, 2011, 2:15 pm
Last edited by DOCa Cola on September 18th, 2011, 4:04 pm, edited 1 time in total.
OMG i go now install Star Trek Armada 1

edit1:
I missed the sound of the menu of armada 1 and also the install sound!

edit2:
Helloo
i have a problem ....
i had just installed Armada 1
and the patch

so i got this :        Armada 1 1.3 Project
     - YouTube
 

i have upload it what is wrong

and befour i upload it i tryed execute/run as admin
and the upload screen was mutch beter but you can not so it becous i filmed later in game...
second film :        Armada 1 1.3 Project
     - YouTube
 




xD i was a little nervous xD so I hanging somewhere in my words xD
Warp for Belgium
posted on September 18th, 2011, 4:06 pm
yes, this is unrelated to the PP. This is a 'typical' problem of the old graphic engine. PP 1.3.0 doesn't fix that issue.
posted on September 18th, 2011, 4:21 pm
do you make another patch later for this problem?
hmm what is PP ? project patch? :blush:
posted on September 18th, 2011, 8:37 pm
First, thank you for this Patch, I am going to install this right away to my Star Trek Armada I install and since it is still the stock game patched to the official patches I think I won't be changing much. Right? But better game play is the reason why I want to download and install this patch, it gives A1 a new lease of life on Vista. Which will be better than before even though it played alright on Vista for me. :)

o3Locked wrote:I dont have my A1 disk anymore :( I dont know what ever happened to it


I don't know if you still have the game installed on your computer, but I found out that you can play Star Trek Armada I without having the A1 disc as long as you have the Star Trek Armada II disc in your computer's disc drive.

I don't have Armada I, was only borrowing it from a friend and after I found out the game played through the A2 disc I felt better having to give it back to my friend. :)
posted on September 18th, 2011, 11:21 pm
a1 will probably play via an a2 disk since activision's trek titles shared copy protection. an a2 disk also allows bridge commander to run. activision were pretty lazy.
posted on September 18th, 2011, 11:34 pm
With the patch i finally got A1 working in a way where i can play the game, but i still have this odd gfx bug.
Image
posted on September 18th, 2011, 11:44 pm
im running nvidia gtx 570 which has problems with armada 2 (ie dx8)  and was amazed that armada 1 worked and looked good in game with only a few minor graphics (ship texture stretching) at certain pan angles on widescreen resolutions (that i could tell)
was amazed

http://i.imgur.com/5QgLX.jpg  at 1280 1024 32bit
posted on September 19th, 2011, 2:19 am
I am having a few problems with the Patch myself, and I'm not even really sure if it installed when I look in the Armada I Directory because there are no changes there and no additional files, no nothing except what was there before. There isn't even a new Read Me file for the Patch in the directory. This I know because I compared the Armada I directory with a saved backup version and the exact same number of files are there.

When I installed the patch, it installed very quickly, like there was nothing to install, I actually clicked next after selecting the Armada I Directory and a second later, I was looking at the Screen from the patch saying that it was installed.

I played Armada I after and the graphics for me looked worse than they usually do, I couldn't actually see any of the Starships of the Klingon Empire. The next strange thing is I was able to play the Klingon Campaign even though I never finished the Federation Campaign, the same can be said for the Romulan and Borg Campaigns as well?

No offense to the Fleet Ops modding team for I know that it must have taken alot to make the patch, but is there going to be something done about the graphics? It is now actually harder to play the game for me, and the stock version didn't have this problem. Is there going to be another patch eventually?
posted on September 19th, 2011, 4:14 am
Im not sure what the issue is after all the patch is only 700 kbs you didnt really expect it to take very long did you? If you wanted to compare the two you should have looked at the size of the folders im sure one is a little bit bigger than the old one.
posted on September 19th, 2011, 7:40 am
Last edited by DOCa Cola on September 19th, 2011, 7:48 am, edited 1 time in total.
@jetnova: You should see right away if the patch was installed successful by looking in the right lower corner of the main screen. If you see 1.3.0 written there, everything installed ok

The problems with the graphics come from armada 1 itself. I am not sure if i can fix them. The graphic interface is OLD. Though "only" two years older than that from armada 2, with directx 7 technically still in another world
posted on September 19th, 2011, 10:17 am
DOCa Cola wrote:@jetnova: You should see right away if the patch was installed successful by looking in the right lower corner of the main screen. If you see 1.3.0 written there, everything installed ok

The problems with the graphics come from armada 1 itself. I am not sure if i can fix them. The graphic interface is OLD. Though "only" two years older than that from armada 2, with directx 7 technically still in another world


No problem. I'm already very glad i can play A1 again. I was hoping you folks had a quick solution.
1, 2, 3, 4, 5, 6
Reply

Who is online

Users browsing this forum: No registered users and 4 guests

cron