Armada 1 in Windows 10

Talk about anything related to old versions of Armada.
1, 2, 3, 4, 5, 6
posted on August 7th, 2015, 1:19 am
Last edited by yochenhsieh on April 2nd, 2018, 4:28 am, edited 2 times in total.
This is the discussion for playing Armada 1 in Windows 10. So far the following are known NOT working:

- Patch to unofficial 1.3
- Play in virtual machine (only software mode works).
- Put nt.dll and start Armada 1 in dxwnd.

Any suggestion are welcomed. Note that:
Armada 1 works in Windows 7, without any problem if you update drivers to latest.
Armada 1 in Windows 8 and 8.1 should be discussed in another thread.

[UPDATE]
Confirmed working with dxwrapper here: https://github.com/elishacloud/dxwrapper/wiki/Star-Trek-Armada-1
Thanks eriedlinger!
posted on August 9th, 2015, 1:34 am
I was able to get Star Trek Armada I to work on Windows 10 64bit. My previous post talks about updating Armada.exe and using DxWnd.exe to launch the game. The post is located here: //www.fleetops.net/forums/armada/armada-1-and-2-crashes-in-windows-8-12199?p=202233#p202233

These two steps are still needed. However, besides doing those you will need to remove the App Compatibility settings for Armada.exe and recreate them.

Step 1: Remove App Compatibility settings
** Note: If you are not comfortable with using regedit.exe then I would recommend against this. But I will tell you what I did in case you want to try it. I could not get it to work without this step.

The only way I found to remove all the App Compatibility settings was by searching the registry and deleting them. Removing them from the file properties Compatibility tab won't remove them all.

What I did was search the full registry for "armada.exe" and when I found an entry if the entry was under an App Compatibility registry key then I deleted it. For your convenience I listed the App Compatibility registry keys below:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\AppCompatFlags

Step 2: Add new App Compatibility settings
To do this all you need to do is:
1. Right-click on the Armada.exe file and click properties.
2. Go to the Compatibility tab.
3. Select "Run this program in compatibility mode for:" and select "Windows 7". Note: from my tests it worked with Windows XP and Windows 8 also but I chose Windows 7.

That's all. at this point you should be able to run Star Trek Armada I in Windows 10 by:
1. Running DxWnd.exe
2. Double-click on the "Star Trek - Armada" item
posted on August 9th, 2015, 4:33 pm
Nothing happens
posted on August 9th, 2015, 10:39 pm
1. Make sure you are running DxWnd.exe as an admin
Right click on DxWnd.exe and click properties. Go to the "Compatibility" tab and enable the "Run this program as an administrator" checkbox.

2: Verify there is a green dot in DxWnd
When you open DxWnd do you see a green dot next to "Star Trek - Armada". If is not a green dot then you need to:
a. Right-click on "Star Trek - Armada" and click Modify.
b. Next to the "Path" there is a button that says "..." click on that button and browse to the path where Armada.exe is located, select Armada.exe and click "Open".
c. Click "OK" to close the window. At this point you should see a green.

Now you should be able to double click on "Star Trek - Armada" to run it.
posted on August 10th, 2015, 6:59 am
That did it.

(Still annoying to start programs "as an Admin" if the account is already an Admin.

I can start it but the game is being run on safe-mode.
posted on August 10th, 2015, 3:26 pm
That did it.

I am glad you got it working!

Still annoying to start programs "as an Admin" if the account is already an Admin.

Yes, this is because of the User Account Control feature that Microsoft added since Windows Vista. For more information check out this page: http://windows.microsoft.com/en-us/windows/what-is-user-account-control

I can start it but the game is being run on safe-mode.

Yes, I have not figured out how to make it run better than that. One option is that you could use VMware Workstation or VirtualBox. However I don't really like running games under a VM if I can help it. I will post more here if I figure out how to run it normally.
posted on August 10th, 2015, 7:15 pm
the problem with running games on virtual box is, i cant move the mouse in there once the game has started.

Its like it stuck at one corner, but i can install the old games on a virtual Win XP and then take the installation folder from it to start it on windows 10. :)

however that only solves the issue with old Install Shield´s which wont start on windows 10.
posted on August 15th, 2015, 4:36 pm
Eriedlinger, thank you for the detailed post. I will give this a try asap.

Can I request that you post this info on AFC? If you prefer, I can repost the steps with credit to you, And provide my own commentary with my experience.

Thanks again for taking the time into getting armada running. Cheers
posted on October 15th, 2015, 11:37 am
Eriedlinger, thank you for the detailed post. Checking if you have one more idea. After using your .zip file and editing the registry, I get nothing. I have a green dot in dxwnd, but double clicking (or right clicking and run) absolute nothing happens. Armada 1 works fine in my 64 bit Windows 7 Pro. I then requested upgrade (last week) and installed with no errors. Everything else works fine in Windows 10 Pro. Thanks for any advice
posted on November 20th, 2015, 2:22 pm
Armada was working perfectly fine for me in Windows 10.

...Until yesterday. I just installed the November update to Windows 10 and suddenly the game no longer works. I've tried every compatibility mode setting. All that happens is the screen goes dark (as normal during loading) and then suddenly i'm back at my desktop. No error messages, no warning noises, just...nothing.

I've downloaded the DxWnd program as mentioned above, and put it in my Armada folder, but I don't understand what i'm meant to do with it. When I run it (as an administrator as specified), there's a white window. That's it. No green dots or anything. There's a menu, but there's no open function when I click on file. So how am I supposed to use it to open Armada? I'm really confused. I've never heard of DxWnd before.
posted on November 20th, 2015, 5:32 pm
sound like it time to move to FO 3.2.7 :D
posted on November 22nd, 2015, 7:48 am
Um, FO is for Armada 2? We´re talking here about Armada 1
posted on November 23rd, 2015, 2:03 pm
Er i know that saying it time he move to FO was all
posted on November 28th, 2015, 7:51 am
I have gotten armada working by following
eriedlinger wrote:I was able to get Star Trek Armada I to work on Windows 10 64bit. My previous post talks about updating Armada.exe and using DxWnd.exe to launch the game. The post is located here: //www.fleetops.net/forums/armada/armada-1-and-2-crashes-in-windows-8-12199?p=202233#p202233

These two steps are still needed. However, besides doing those you will need to remove the App Compatibility settings for Armada.exe and recreate them.

Step 1: Remove App Compatibility settings
** Note: If you are not comfortable with using regedit.exe then I would recommend against this. But I will tell you what I did in case you want to try it. I could not get it to work without this step.

The only way I found to remove all the App Compatibility settings was by searching the registry and deleting them. Removing them from the file properties Compatibility tab won't remove them all.

What I did was search the full registry for "armada.exe" and when I found an entry if the entry was under an App Compatibility registry key then I deleted it. For your convenience I listed the App Compatibility registry keys below:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\AppCompatFlags

Step 2: Add new App Compatibility settings
To do this all you need to do is:
1. Right-click on the Armada.exe file and click properties.
2. Go to the Compatibility tab.
3. Select "Run this program in compatibility mode for:" and select "Windows 7". Note: from my tests it worked with Windows XP and Windows 8 also but I chose Windows 7.

That's all. at this point you should be able to run Star Trek Armada I in Windows 10 by:
1. Running DxWnd.exe
2. Double-click on the "Star Trek - Armada" item


Hey Guys. I followed the above steps and the game works perfectly. However... the graphics are terrible because the dxwnd application is restricting graphics controls.
I know from experience these graphics are low quality settings. The settings in armada are fixed because of the application. Was the whole point of this fix to play half quality on win 10???
I attached a photo of the graphics quality I am talking about.

Attachments

sta.jpg
sta.jpg (197.62 KiB) Viewed 20977 times
posted on November 28th, 2015, 11:30 am
That is the so called "Safe-Mode"
1, 2, 3, 4, 5, 6
Reply

Who is online

Users browsing this forum: No registered users and 3 guests