EConvertError '0,280000001192093' is not a valid floating po

Program aborts? Network configuration? Graphic errors? Bugs? Post your question here.
posted on May 26th, 2019, 6:15 am
Hi ladies and gents.

I have a following error when starting clean installation of FleetOps (latest) on Windows 10:

Code: Select all
executable        : Armada2.exe
current module    : FleetOpsHook.dll
module date/time  : 2012-10-20 13:40
version           : 3.2.7
callstack crc     : $ed084711, $329eb371, $329eb371
exception number  : 1
exception class   : EConvertError
exception message : '0,280000001192093' is not a valid floating point value.

main thread ($398c):
5a858499 +019 FleetOpsHook.dll SysUtils       74  +0 ConvertErrorFmt
5a85ac2e +02e FleetOpsHook.dll SysUtils       74  +0 StrToFloat
5a92cd40 +178 FleetOpsHook.dll INISerializer  44 +25 getOrSetXmlPropValue
5a92d1c5 +1a1 FleetOpsHook.dll INISerializer 108 +14 UnMarshall
5a92de0b +063 FleetOpsHook.dll FoSettings    189  +5 TFoSettings.getInstance
5a9d9912 +052 FleetOpsHook.dll FleetOpsHook  225 +21 initialization
760f3c72 +142 KERNELBASE.dll                         LoadLibraryExW
760f22d1 +021 KERNELBASE.dll                         LoadLibraryExA
760f216d +02d KERNELBASE.dll                         LoadLibraryA
776c323d +14d ntdll.dll                              LdrInitializeThunk
776c3107 +017 ntdll.dll                              LdrInitializeThunk

thread $2548:
776c3229 +139 ntdll.dll  LdrInitializeThunk
776c3107 +017 ntdll.dll  LdrInitializeThunk

Can you please help me running this awesome game once again?

My Digit grouping symbol is ","

My decimal symbol is "."

posted on May 26th, 2019, 6:04 pm
I have no idea about Win 10. Usually, Fleet Operations worked just fine with Win 7 and Win 8.1. If you have Linux - Ubuntu or Mint - just click here > ... untu-13820
posted on May 28th, 2019, 6:02 am
I'm not familiar with that particular error message, but the most likely problem with Windows 10 is that the program is installed somewhere where W10 prevents certain kinds of code from running. I would start with Run as Administrator and Compatibility Mode, then if that doesn't work try moving the folder around and running it from different places.
posted on May 28th, 2019, 11:48 pm
I've never had any issues with FleetOps on Windows 10 and that's with upgrading from Windows 7. This includes having multiple copies of FleetOps. One installed on the Hard Drive and others on USB Flash Drives with different Mods.

If you're having issues with your install you could always Google it and download Full Installed Versions of FleetOps that people have placed online that are the full installs in .ZIP or .RAR formats and extract them to your computer and delete/uninstall your not working copy. The game will still work using such files.
posted on May 1st, 2020, 1:44 pm
I had the same problem, whenI changed my Windows (Win10) language:
Display language: English
Preffered language: German

After changing the display language to German it worked again!
posted on May 12th, 2020, 1:39 pm
This seems to be related to some settings saved in Fleet Operations' settings file. You can delete the settings file and it would fix this issue. Alternatively you can open the file and fix the floating point values according to your system locale.

You can find your configuration file under XP
C:\Documents and Settings\<your username>\Application Data\Star Trek Armada II Fleet Operations\FOData.ini
or Vista/7/8/10
C:\Users\<your username>\AppData\Roaming\Star Trek Armada II Fleet Operations\FOData.ini

note that these folders may be hidden in the default configuration of Windows.

An alternative way to reach this file:
Open the Run dialog (i.e. by pressing the Win + R keys on your keyboard simultaneously)
Copy&Paste the following:
Code: Select all
%APPDATA%\Star Trek Armada II Fleet Operations

Click "OK"

Who is online

Users browsing this forum: No registered users and 2 guests