Something strange with 2 mods

Talk about anything related to old versions of Armada.
posted on March 18th, 2013, 7:13 am
This doesn't refer to my STA2_Generational Mod, instead it is from two mods that I have posted bug reports to, the Star Wars Fleet Command Mod and the StarGate: Rise To Power Mod.

Recently I have posted 2 bug reports related to these mods based on stock A2 that obviously are confusing because no one has said anything about them and Dominus_Noctis said he couldn't understand these two bug reports.

Well, there is something strange going on with these two mods. If I choose to not see or generate the bug reports, and then double click on the splash image that appears on the desktop, the mods launch. The Star Wars one actually lets me play Instant Action without any problems, the StarGate mod doesn't allow that but I have tested that mod though the Map Editor with some units and have seen that the game is playable it just won't launch after setting up an Instant Action game and crashes without generation a bug report. I tell it to but it just won't do so.

The attached picture is from the Star Wars Fleet Command Mod in the game:
Star Wars Fleet Command (The Original) - Gives the same message as the StarGate Mod, both can actually be forced to run after closing the popup.jpg
Star Wars Fleet Command (The Original) - Gives the same message as the StarGate Mod, both can actually be forced to run after closing the popup
Star Wars Fleet Command (The Original) - Gives the same message as the StarGate Mod, both can actually be forced to run after closing the popup.jpg (97.29 KiB) Viewed 447 times

Error Message When Trying To Launch Both Mods.jpg
Error Message When Trying To Launch Both Mods
Error Message When Trying To Launch Both Mods.jpg (36.84 KiB) Viewed 447 times

Star Wars Fleet Command (Original)_exception.txt
Star Wars Fleet Command (Original)_exception
(20.9 KiB) Downloaded 143 times
posted on March 18th, 2013, 7:21 am
Here is the last Bug Report related to this post and the strange fact that these two mods actually will load after ignoring the bug report and memory "problem" and just double clicking on the splash screen image allowing the game to start.
StarGate_Rise To Power_exception.txt
StarGate_Rise To Power_exception
(20.29 KiB) Downloaded 136 times


Has anyone ever had such a thing happen or ever tried to see if such a thing would happen?
posted on March 18th, 2013, 5:10 pm
Hi. I played with Star Wars Fleet Command under my windows 7 OS, and runs very well without any problems. This is the mod used by me to create my Star Wars Mod for Fleet Ops. I had to do only a few updates, changing some textures on the battleships or adding some new ships for the game. Maybe I can suggest to re-install your OS, because I don't know why you have so many error reports when you playing this game, but I do not get any error messages when I played with SW Fleet Command. I can't tell nothing about your StarGate version because I don't have it. You can get a message report because maybe, when some files from the mods is installing somewhere else, they collide somewhere and the result is a message error. A clean install would be nice before playing a mod. I don't have another idea.
posted on March 18th, 2013, 6:31 pm
Well I did fix the creators major problem of omitting the ships directory in the ODF directory, and also got rid of the stock races ships and stations because if you check the Star Wars Fleet Command mod's races.odf they are no longer in the game as races. So why keep obsolete useless files? The corresponding BMP and SOD files for the stick original (Star Trek) ships and stations were also removed since they are what corresponds to the mods removed races by the creators of the mod. Frees up a lot of space on the hard drive that mod took up just with unused files.

Maybe someone can duplicate that and see if it causes any problems?

Also one thing you have to remember Miklosgo that might be relevant is I am using the true A2 disc to play, no mounted disc or ISO file. If I ever use an ISO, its a ISO burnt to a disc thus an exact copy of the A2 disc.

My laptop's OS is fine if there was a problem with it, I'd know and two I can't just reinstall my OS when it already came with the laptop Pre-installed. All I can do is a System Restore and that wouldn't have any effect except destroying/erasing many of my installed programs, information for Youth Group and also church, not to mention what I need for school and work.

I've tried it on other OS though with the same problem and a newer computer (desktop) running Windows 7, same bug report and same problem. The same happened with your Star Wars Fleet Command Mod for FleetOps.

Of course one logical thing, if it was something to do with the OS, other mods and stock A2 wouldn't run either and that includes the stock version of my STA2_Generational Mod. Tests with those mods don't duplicate the problem, if it was something to do with the computer or its OS, wouldn't it logically also be causing problems with every other mod?
Two out of 7 stock mods having a problem, doesn't constitute an OS problem or a memory problem either, the process of elimination leaves something to do with those mods especially if everything else works fine including the rest of the computer, other games and installed programs.
posted on March 18th, 2013, 9:18 pm
sorry cant help here as it looks like its using pp not fo does seam bit odd if the mods work without the pp
posted on March 18th, 2013, 9:37 pm
@Blade: Actually from what I see both mods are using the Patch Project 1.2.5 Patch in one way or another. Especially the StarGate one, I've noticed the Max Buildable # coding:
Code: Select all
maxBuildableNumber = 6
in many of the ODF files, that's only available in the PP, so I'd guess its needed.

As for the Star Wars Mod having the patch, its for two reasons:
(1) I don't run any mods on Windows Vista or Windows 7 without it, even the stock game because without it I've had errors that made the game not run smoothly on those operating systems without it. Some people just get lucky I think and have it work without it, I'd be willing to bet their systems were originally using Windows XP or less because I've found the game works perfectly fine without the PP on systems that have Vista or Win. 7 but had an earlier OS before that, I'd guess its all in the hardware and not the OS.
(2) Without the PP, you don't get any Bug Reports for stock A2, so in my expert opinion it's best to have it in any mod for stock A2 that way you can most likely find out why the game crashed instead of pulling out your hair.
Reply

Who is online

Users browsing this forum: No registered users and 2 guests