Win10 Instant Action Crash - Access Violation

Program aborts? Network configuration? Graphic errors? Bugs? Post your question here.
posted on November 30th, 2018, 5:18 pm
Last edited by InfinityYUL on December 1st, 2018, 4:26 pm, edited 2 times in total.
Edit: Direct3D error please reboot was the main issue, either having multiple monitors or monitor duplication was the cause,. Fixed by launching game with only 1 monitor plugged in.


Hello, I've played this some time ago on a Windows 7 machine without issue, but now on my Windows 10 machine it just will not work.

At first I had a Direct3D error that was resolved with turing the D3D9=false to true, but now I get a 'Access violation - Armada2.exe' and no matter what I've tried it does not work.

So far I have tried, but not limited to changing the Compatibilities, Exceptions, exes from No cds, suspect d3dx.dlls, fresh install both with and without Armada2.

I tried getting it going on a Windows 7 machine and it worked first time without issues. I know some programs I have need additional things to be installed like C++ Redistributable from 2005-2017, but I'm at a loss and have no idea why it works on 7 but not 10.

If someone would be kind enough to give step by step directions on how to get it working on Windows 10 that be great, a list of any additional programs such as Microsoft additions like the Redistributables above could prove useful too. I'd like to try and find the difference between me and someone with a working install on Windows 10 versus posting a crash file or what not.

I miss playing this, it's great.
posted on November 30th, 2018, 7:44 pm
I've never had any problems with FleetOps working on Windows 10 and my computer was upgraded from Windows 7 where it also worked perfectly. Even with the current version of Windows 10 there isn't any problems getting FleetOps to work or even Armada II Mods using FleetOps. It's worked with no problems on multiple computers using Windows 10.

I'd have to say it's your hardware and not directly Windows 10 then that's causing you problems. Are you using a computer that used to be originally made for Windows 7 and then upgraded to Windows 10? That would mean it's still using the original hardware from the Windows 7 computer.
posted on November 30th, 2018, 8:14 pm
I do find this odd, not ruling out it's a me issue, but from searching the forums and google finding others with this issue and no solution makes me think there's more to it then just install and play.

So far I've only had issues with fleet ops on this machine, I am using Windows 10 not a upgraded Windows 7, it's a full format install, all things updated.

I now have plans to try Windows 10 on the Windows 7 machine that is playing fleetops just find in the coming days, full format fresh install, if it is a hardware issue I guess that would answer that.
posted on December 1st, 2018, 3:16 am
i am repeating this again , i just copy fleetops from working instal on win xp machine like 10years ago. i have backup on usb drive and one old hdd, works like charm every time ... on win 10 or 8 . no issues.
posted on December 1st, 2018, 5:22 am
InfinityYUL wrote:I do find this odd, not ruling out it's a me issue, but from searching the forums and google finding others with this issue and no solution makes me think there's more to it then just install and play.

So far I've only had issues with fleet ops on this machine, I am using Windows 10 not a upgraded Windows 7, it's a full format install, all things updated.

I now have plans to try Windows 10 on the Windows 7 machine that is playing fleetops just find in the coming days, full format fresh install, if it is a hardware issue I guess that would answer that.


I would strongly recommend not formatting and doing a fresh install of Windows 10 from Windows 7 but to strictly just Upgrade; as in doing an "inplace" upgrade. You can easily erase in the formatted installation the working drivers from Windows 7. During the Upgrade Windows 10 updates the drivers that are needing updates to fully work with the new OS. A large majority of the drivers on my computer never needed Windows 10 updated drivers and it's still using the Windows 7 versions. Doing a format fresh install you risk Turing your working computer into one like the Windows 10 that doesn't have FleetOps working.

Also Shadow24 is right as well.
Shadow24 wrote:i am repeating this again , i just copy fleetops from working instal on win xp machine like 10years ago. i have backup on usb drive and one old hdd, works like charm every time ... on win 10 or 8 . no issues.


All my installs of FleetOps are on USB Flash Drives or External Hard Drives so that they are transferable to any computer without ever having to install FleetOps ever again. All those versions work 100% on Windows 10 and also make it far easier to have a working FleetOps install plus saves a lot of time.
posted on December 1st, 2018, 6:54 am
Oh, I see, so no one has a successful install on Windows 10?

Is it possible to share this USB fleetops install? I have the Armada2 CD so if sharing the ldl/exe is a issues I can use my own.
posted on December 1st, 2018, 3:38 pm
Alrighty then Fleet Operations works now, I found the problem and have fixed it, sort of, I unplugged my additional monitors...

Either it's multi monitor or display duplication causing the issues, I have been at this for a long time and will not bother to figure out which one, I'm done, I'm happy. Writing this for posterity and respect to those who read and tried to help me in enjoying the greatness that is Fleet Operations.

My first issue was the Direct3D error please reboot thing, solved by changing D3D9=false to true, and from there it snowballed into me creating my own problems.

I went ahead and fresh installed Windows 10 on my Windows 7 machine and tried a direct copy of the fleetops install from my 'new' Windows 10 machine that was playing fleetops just fine. It still did not work on my 'original' Windows 10 machine giving me the Direct3D error again, so I started to check the differences.

When I unplugged all but 1 monitor, the game worked!!!

So now a small sacrifice to play this game is a reach around to unplug some monitors and I'm more than fine with that. That said, if I, or anyone, finds a way to fix it will definitely post it here.

That's all it was, and thank you all. - LLAP

Edit: typo/clarification
posted on December 2nd, 2018, 9:36 am
Why do you need Windows 10 anyway ?

Well, if You bought a new computer, it's understandable. On the other hand, Microsoft extends paid Windows 7 support until 2023 and for Windows 8.1, Extended Support will end on January 10th, 2023.

I switched from Windows to Linux, using Ubuntu Linux: https://www.ubuntu.com/desktop
You can play a lot of native games using Linux and many Windows games using Playonlinux.

You can run Windows OS under Ubuntu Linux using VirtualBOX, if it's necessary : http://www.junauza.com/2010/01/how-to-install-windows-7-on-ubuntu.html or https://itsfoss.com/install-windows-10-virtualbox-linux/
posted on December 4th, 2018, 2:05 pm
InfinityYUL wrote:Oh, I see, so no one has a successful install on Windows 10?

Is it possible to share this USB fleetops install? I have the Armada2 CD so if sharing the ldl/exe is a issues I can use my own.


I think you're mistaken, that's just my personal computer that was upgraded from Windows 7 to Windows 10 and FleetOps was originally installed in that Windows 7 but moved to a removable USB Flash Drive to be useable on multiple computers because it's far more practical than installing on many computers.

I have a few people I know from work who installed FleetOps on new Windows 10 computers using the Armada II disc and they haven't had any problems with installing or running the game. If anything really it shouldn't be on their work computers.

I'm sure a few sites if Googled can find you a USB installed version. You could even try copying it from your working Windows 7 PC to Windows 10. The thing is it could still be that computer. You said it's a "Access Violation - armada2.exe" but are you also getting a bug report? You should be able to find that in another location, I'm not near my computer but I believe it's in a "Roaming" folder. I created a shortcut to that folder on my USB that holds FleetOps as well.
Reply

Who is online

Users browsing this forum: Google Adsense [Bot] and 3 guests

cron