Unknown crash

Program aborts? Network configuration? Graphic errors? Bugs? Post your question here.
posted on May 27th, 2015, 2:15 am
I got this crash while playing as Federation against Imperials and Rebels on my star wars mod. I don't know what it means or how to fix it. Was playing for about fifteen minutes if that. But all three sides were fully developed maybe it had something to do with all the objects on the screen at the time, my star wars mod has lots of fighters in it.

Attachments

exceptArmada2.txt
(27.44 KiB) Downloaded 307 times
posted on May 27th, 2015, 2:47 pm
Seems to be an AI Crash. Have you tried testing each side out 1 on 1 to ensure the AI buildlists (usually the cause of AI crashes) are correct?
posted on May 27th, 2015, 6:35 pm
What do i look for though, a misspelled item or something out of order?
posted on May 27th, 2015, 7:03 pm
More likely a misspelled item (or missing a required parameter after). An item out of order would just result in a "producer not available" and the AI simply stopping.
posted on June 6th, 2015, 7:16 am
Hi Spartan. Your Star Wars Mod it's awsome and it works perfectly for me. Why do you have a chrash on your computer ?

Send me a mail and I can send you back your mods, probably you made some modifications somewhere and it just collapse . Sorry for that, because you made an excellent mod :-)
posted on June 6th, 2015, 5:31 pm
Hmm I have this crash now too. I wonder if it and the "Tally Effectiveness" crash are related?
posted on June 6th, 2015, 6:36 pm
I got this crash this morning playing against the Dominion as the Rebels. Still don't know what causes it.
posted on June 8th, 2015, 6:22 am
The theme (and ergo most of the coding) for your mod and my own is radically different. However I can think of one thing in common; Fighters.

Being Star Wars, your mod has ships coded as fighters, and mine has fightercraft coded to emulate SFC/KA combat. Could that be the common thread that brings both our mods the same crashes?
posted on July 23rd, 2015, 4:05 pm
Right, I don't know if this helps, but I've found something a little....odd.

As I said, I was getting this crash. I had a multi race (all 8 races in my mod) game with 3 sides (Fed, Gorn, Hydrans vs Klingons, Romulans, Lyrans vs Tholians and ISC)

I figured might just be "overloading" something. Asking too much of the game engine.

I decided though to run tests and see at what point it crashed and why. Now I've managed to isolate it to that specific map (a large map I made called Arena, sort of a squished version of the Alpha and Beta Quadrants) and to a specific side, in my case the Gorn Confederacy. No other race crashes, and the Gorn work fine on other maps.

If any Devs could shed any light onto what exactly these crashes mean, it would be helpful. Right now all I can really do is shrug, as I can't work out the root cause. It's not the build list, it's not anything different in the AI file itself (priorities etc) I'm just baffled.
Reply

Who is online

Users browsing this forum: No registered users and 3 guests