Reflection

Program aborts? Network configuration? Graphic errors? Bugs? Post your question here.
posted on January 14th, 2017, 9:13 am
How do I edit the materials in Milkshape so they reflect ambient lights? I just can't figure it out!

I added !phong and !opaque strings to the name of the texture name, I also added some light to the ambient/specular side but nothing happened. All I managed to do is that unlit ships aren't dark any more... I'm sure the solution is something ridiculously simple I just can't figure it out... :o
posted on January 14th, 2017, 7:09 pm
Wow, I didn't know you were still around much these days k_merse. Awesome to see you. All I did was add !phong_ to the front of the texture name in MIlkshape then make sure the colors for Ambient and Specular are black and set Diffusive and Emissive to white.
posted on January 15th, 2017, 9:26 am
Yeah I'm still kicking. I have this decade-old dream of creating the Big Mod which drags me back to Armada time and again :lol:
Anyway only adding the !phong string doesn't solve the issue for me. Maybe it's something with the texture lightmaps? I think I reproduced exactly the setup used on the FO models and nothing :hmmm:
posted on January 15th, 2017, 8:40 pm
Sorry about that k_merse. I had forgotten the texture part. Been a while since I did this. Here's a little tut I downloaded years ago to add lightmaps to textures in GIMP if you have it.

The pics below are from my mod here on site. Is this what you're looking to do?

download/file.php?mode=view&id=13570
download/file.php?mode=view&id=13569
download/file.php?mode=view&id=13568

Attachments

INH Lightmap Tut for GIMP.zip
(874.63 KiB) Downloaded 18 times
posted on January 16th, 2017, 6:15 pm
Exactly :woot:
Thanks, I'm gonna try it out later this week.
posted on March 18th, 2017, 2:22 pm
I got there now to try your solution out but it did not work... My problem is not that I don't have lightmaps but that I don't have reflections of outer lightsources. I get that far that my ships have shadows depending on where the main light source is coming from, but I can't make for example the dilithium moons to cover the starship hulls in blue....
posted on March 19th, 2017, 5:24 am
Well, the way to test if phong textures are working is weapons fire; if your weapons are coded to produce light, you will get them shining on the hull of a ship.

YamatoTestFire.jpg
YamatoTestFire.jpg (193.14 KiB) Viewed 43 times


Notice the purple lighting from the Assault Phaser.

If that works, but you are not getting light from moons etc, you might need to add a light source to those objects. The Storm3d engine isn't very advanced lighting wise, so it doesn't always work properly.
posted on March 19th, 2017, 7:01 am
The problem is that some models get reflections and some don't. And I can't tell the difference! The MS3D setups are identical so I guess the problem may be with the tga files but I cant figure out what exactly... They seem to have proper lightmaps, narcelles and windows are light even in the dark, except with some models I get reflection colors, with some, I don't.
It drives me nuts....
posted on March 19th, 2017, 8:08 am
Well, all I can suggest it to double check the following;-

All models have their textures set as !phong_TEXTURENAME in Milkshape3d. Make sure it doesn't have _!noalpha as a suffix.
All models textures have specular, emissive and ambient all set to pure black (0, 0, 0) and diffuse set to pure white (255, 255, 255)
All models are exported as A2 SOD (rather than A1 SOD) in Milkshape3d
All models textures are 32bit tgas with alpha layers, and those alpha layers are set so that unlit is pure black ( 0, 0, 0 ) and fully lit is pure white ( 255, 255. 255 ). I have encountered some textures where whoever made it did not do this, so that even when completely unlit, the alpha isn't quite black (5, 5, 5 for example)

Note: When you import 3d models into Milkshape, their textures will default to having a _!noalpha suffix and a pure white emissive setting. This is okay, as long as you remove the _!noalpha and alter the emissive back to pure black before exporting again.
Reply

Who is online

Users browsing this forum: No registered users and 2 guests

cron