RankUp Crash In A Mod With No RankUp

Program aborts? Network configuration? Graphic errors? Bugs? Post your question here.
posted on November 2nd, 2017, 5:36 pm
I've been working on converting a FleetOps Star Wars Mod back to being an Armada II proper mod that is its own mod within a Parent Star Wars Mod (Star Wars Fleet Command) using the Armada II in FleetOps (A2 Classic) that Miklosgo put out. Within this mod I've been able to put together its own Mods Directory and have mods working there.

This problem pertains to one of those mods.The problem I am having with this mod unlike others though has to apparently do with Rank Ups yet this mod has no Rank Up/Upgrade Ships or Stations in it; I removed them all and all coding pertaining to it. I'm also using edited stock ODF files using the hardpoints, weapons, and tooltip from the original FleetOps Star Wars mod's ODF files. I am also using the original SOD files. Even with all these edits every time I load an Instant Action game it crashes at 100% of loading and them I'm getting Bug Reports that says: Craft_mLevelUp and Craft_Simulate_Callback under the call stacks section of the Bug Report.

I'm Including the Screenshots I took from the Bug Report Within Game as it was generated for that is what I currently have access to.
Screenshot 2017-11-02 00.12.47.png
Screenshot 2017-11-02 00.12.47.png (82.69 KiB) Viewed 125 times

Screenshot 2017-11-02 00.14.36.png
Screenshot 2017-11-02 00.14.36.png (60.41 KiB) Viewed 125 times

Screenshot 2017-11-02 01.30.55.png
Screenshot 2017-11-02 01.30.55.png (70.29 KiB) Viewed 125 times
posted on November 3rd, 2017, 4:31 am
So, there are rank-ups in the odf files, and replaceweapons (which are almost the same thing), and these don't need to be used.

But then there are dll files related to ranking up, and they are part of the modified framework the devs created. You cannot remove any dll files and still have it work. Even if you don't use rankups, you still need to have the libraries that define them since they are part of the game's .net framework.
posted on November 3rd, 2017, 5:51 am
Tryptic wrote:So, there are rank-ups in the odf files, and replaceweapons (which are almost the same thing), and these don't need to be used.

But then there are dll files related to ranking up, and they are part of the modified framework the devs created. You cannot remove any dll files and still have it work. Even if you don't use rankups, you still need to have the libraries that define them since they are part of the game's .net framework.



Thanks Tryptic, I just still don't get it. I have nothing referring to RankUps in any ODF files. I use the ReplaceWeapon coding in some Special Weapon ODF files to launch fighter from carriers and other ships in multiple mods without any such problems. Of course these are slightly in line with the Armada II Patch Project ReplaceWeapon coding and my own workable files.

I didn't edit these ODF files like that. I just removed all RankUp coding (commented it out really) in the Fighter launching files and removed the extra Fighter names from the files for the Ranked Up versions from the original mod. Should I use my normal Fighter Launching files that I'd normally use via the Armada II Patch Project instead?

I wasn't planning on deleting any of the .dll file she because I really didn't think they were the root of the problem and I figured the game needs them anyways.

Not sure if I stated it earlier was thinking I did but the base mod of Armada II in the FleetOps Engine uses FleetOps 4.0 (as in the FleetOps 4.0.0 Loader).
posted on November 3rd, 2017, 9:45 pm
With what free time I could gather this afternoon I edited up all the Fighter Launching files and the other files I found with "ReplaceWeapon" in them to use the ones that I have working in stock Armada II mods as well as FleetOps mods based off of Classic Armada II; using the kind that were able to be made after the Armada II Patch Project Patch's release that made it possible to use MVAM with the Prometheus-class starship.

This editing didn't take long but the results were undesirable with the same crash occurring as exactly as before. If I didn't previously stated it before, this crash occurs right after the entire load bar for Instant Action has loaded 100%. The game waits like a second or two after that and then crashes giving the exact same Bug Reports. I have noticed that in the FleetOps Guide for the Bug/Crash Checklist it lists that Loading Crashes at 100% are possibly caused by:

A Crash Happens when the load-screen progress bar have moved 100%
1. There is something wrong with a unit's ODF with the faction you are playing as. Usually a spelling mistake.
2. The unitName GameObject string is longer that (I think the writer meant "than") 112 characters.
3. Extra or missing quotation mark in an ODF command string.

I've gone through all the files and haven't found any possible bugs related to those 3 points.

Newer Bug Report Screenshots; I think the info is mostly the same:
Screenshot 2017-11-03 16.32.12.png
Screenshot 2017-11-03 16.32.12.png (47.31 KiB) Viewed 94 times

Screenshot 2017-11-03 16.32.13.png
Screenshot 2017-11-03 16.32.13.png (79.09 KiB) Viewed 94 times

Screenshot 2017-11-03 16.32.21.png
Screenshot 2017-11-03 16.32.21.png (51.44 KiB) Viewed 94 times
posted on November 3rd, 2017, 9:46 pm
One more screenshot, I didn't realize 3 was the max.
Screenshot 2017-11-03 16.33.38.png
Screenshot 2017-11-03 16.33.38.png (70.59 KiB) Viewed 94 times
Reply

Who is online

Users browsing this forum: No registered users and 3 guests