Parallels Crash on M1 MacBook

Program aborts? Network configuration? Graphic errors? Bugs? Post your question here.
posted on November 30th, 2021, 4:37 am
This is a long shot but I figured I would ask. Has anyone gotten Fleet Ops to work successfully on one of the new M1 Macs either in Parallels or Crossover?

In Parallels Fleet Ops just instant crashes with error 0xC0000005. Tried all the Windows 11 compatibility modes and looked at the other solutions on here such as disabling anti-virus (none installed) without success.

Also tried it in Crossover but it just never opens when I try to launch the app (no error code). The app icon appears in the dock then quickly disappears.

I used to play Fleet Ops occasionally in Windows 10 via Boot Camp on my old MacBook but that's no longer an option. Thanks for any help!
posted on December 16th, 2021, 9:10 am
If anyone needs help with this in the future it appears I have gotten Fleet Ops working by buying the newly released Armada 2 on GOG and then after installing it copy it's version of Armada2.exe to replace the one installed by FleetOps.

After doing so I am able to load Fleet Ops and start playing a game without issue. I'll report back if I experience any crashes down the line. Excited to have the last game I wanted working on my MacBook. :)
posted on January 16th, 2022, 6:41 pm
Amazing! I registered just to confirm and say thank you!

Honestly never expected someone else to be trying this :lol: :lol:
I feel like I had to do this same fix back on Windows 10 when I had a Windows machine. Feels familiar. But yes, now got FleetOps running in Parallels on an M1 Max :lol:
This is what work machines were built for! Thank you!
posted on March 10th, 2022, 5:51 pm
This is exactly the problem Im having. Do you have the step for step instructions available, it still doesnt seem to work for me.

Who is online

Users browsing this forum: No registered users and 3 guests