Only map editor crashed, gameplay works [fixed]

Program aborts? Network configuration? Graphic errors? Bugs? Post your question here.
posted on October 24th, 2019, 1:57 pm
Last edited by yochenhsieh on October 25th, 2019, 12:05 pm, edited 1 time in total.
Version: 3.2.7
Haven't played fleetops for some time. Today I found that map editor will crash at loading, but gameplay still works.
Log is attached.

To reproduce:
1.Start fleetops
2.Select map editor
3.Edit a existed map or start a new map
Game crashed at loading

Attachments

exceptArmada2.txt
(96.1 KiB) Downloaded 12 times
posted on October 24th, 2019, 5:32 pm
ODFs are missing for your ODF directory. At least one. The error log says that it can't find the Borg Incubation files. It can be a typo in the menu odfs (edit_xxxxxxxx.odf) or that some ODF of the Bord Incubation Center is missing/corrupted/deleted.
posted on October 25th, 2019, 12:04 pm
This is very odd. I didn't touch any Borg related files. (Not interested in them)

However, my other fleetops 4.0 has map editor working. I noticed in the log the module Armada2.exe was from a non-existed dir. So I tried these steps:

1. delete "%USER%\AppData\Roaming\Star Trek Armada II Fleet Operations" folder.
2. start fleetops 3.2.7, still crashes.
3. start fleetops 4.0, accept map editor license.
4. start fleetops 3.2.7, accept map editor license.
Now map editor works.

Quite weird.
posted on October 25th, 2019, 4:17 pm
Sometimes the map editor crashes for me too, but a computer restart always solves the problem. Well, I always knew that computers have souls too :lol:
posted on October 30th, 2019, 5:04 am
im having the exact opposite problem. Im able to load a specific map I wanna play on.. But when I go into Instant Action, game crashes.

This is my personal mod built on top of Fleet Ops 3.2.7.

Loading bar is getting about 60-65 percent Id say and then CTD. No crashlog file. just straight CTD. Ive gone over the files im using for Instant Action soooo many times with absolutely zero success. I got it to load one time.. it froze so i had to reboot.. and then it has not loaded once since then.

Yet this exact, same build of my mod.. works on my old computer which is Windows 10 Home... just that the cpu and video card aren't good enough to power through it.

I built Ryzen machine for Destiny, Division and Forza, and figured, hey why not get Armada running.

Any thoughts would be appreciated. Id even be happy to pack up the game files (minus sod, textures, sounds) for someone to take a look at. Cause Ive exhausted everything I can think of.
posted on October 30th, 2019, 8:34 am
That seems like a complex issue with so many possible reasons. Can you load the map in the map editor? Can you even start playing on it in the map editor?
posted on October 30th, 2019, 1:34 pm
yes. ill take a map... say Naleri Expediton. Ill drop a Sovereign an a Keldon on it. No crash. Ill set my Instant Action units in the race files to be those two ships only, one on each side. Load up instant action on the same map, and CTD. I got it to load one time yesterday and then as I was traveling across the map with my ships to fight the other ships i set up, the game froze. Like not even Ctrl+Alt+Delete could free up the system. had to power off and reboot my computer. Mind you I legit just built a brand new Ryzen 5 3600 system... i can play destiny, division, forza, all at around 90-100fps.. so its def not my specs.

Anyhow... i reboot.. load map editor again.. everything is fine.. go to load the game. Crash. Same map, Same ships.. same conditions. Different result.
posted on October 30th, 2019, 1:41 pm
also a majority of my mod was built on a version of FleetOps that was before the Avatar and Rankup system. If I could find that version again..I could use it as a base to rebuild my mod a piece at a time.
posted on October 30th, 2019, 7:25 pm
This definitely looks like an ODF issue. I noticed that weapon and ordnance ODFs could cause crashes similar to this. Or sometimes invalid spr entries.
It is possible that there is something coded differently in the old FO version and that causes teh CTD in instant action, but I have no idea what it is.
If I were you, I would just try to rebuild the mod step by step. It would be faster.... :sweatdrop:
posted on October 30th, 2019, 8:50 pm
yup.. i found JanB's roots mod.. which is amazing by itself! and ive started retooling the Federation to my liking... I want to add attack patterns. Because it just makes sense.. wish there was a way for the AI to use them as well
posted on October 31st, 2019, 8:42 am
Attack patterns are easy. Just make them as replaceweapons and replace the ship using it with a "buffed" variant then automatically revert it when the pattern wears out. That's how I did it ;)
posted on October 31st, 2019, 3:48 pm
i mean the actual movement (cloverleaf, circle, etc.) So that ships will move, strafe.. look like they are trying evasive maneuvers...


Merse... could you provide me with an example?
posted on November 1st, 2019, 9:17 pm
Oh, you mean those....
What I meant were some STO-like temporal buffs. Basically you use a replaceweapon to replace a Galaxy Class with another Galaxy Class, but with 2x shield regeneration for example. Then you use another timed replaceweapon to automatically revert it to the original Galaxy once the attack pattern buff runs out.
posted on November 1st, 2019, 9:30 pm
yup.. i mean those LOL i was going through my personal mod files and trying to figure out how i readded them in the past.. once i figure that out.. im gonna look into making new buttons for them so they fit in better.. wouldn't mind some help if anyone has any ideas..

gotta see if can find a copy of photoshop somewhere that i can, ahem, install LOL since i didn't put a ROM drive into this new rig.
posted on November 1st, 2019, 11:03 pm
i use some race specific computer overlays for each race , star trek only !
stuff from films and series to feel more trekkie :woot:
Reply

Who is online

Users browsing this forum: No registered users and 3 guests