Is #define MAX_ELEMENTS 200 hardcoded?

Program aborts? Network configuration? Graphic errors? Bugs? Post your question here.
posted on August 5th, 2018, 11:48 am
I'm struggling with the AIP file for my mod at the moment as I hit the 200 entry mark.
Is the number 200 hardcoded or can it be changed? If it can, then how? I tried to delete the #, the game launches just fine, but the AI doesn't build anything then. I tried to incorporate it into other parts of the AIP file, tried every trick in my (limited) disposal to make it work but I'm stuck. Either the game crashes because there are to many line sin the faction AIP file, or the AI won't build anything clearly indicating that it doesn't have access to (the construction list part of) the faction AIP for some reason.
posted on August 23rd, 2018, 4:50 am
Personally I found there is no way past the #define MAX_ELEMENTS 200 so I believe it is hard coded. I discovered that trying to get the AI to build ships from every era of Star Trek as well as combining the Dominion Ultimate Mods with the Cardassian stock race and the game eventually just started crashing on loading any race.

I found a way around this for the era's by using the Mods directly and setting each Era as their own mod. In the case of the Cardassians and the Dominion and Breen of the Dominion Ultimate Mods I had to chose my favorite Dominion and Breen ships and stations and only use them.

So what I'm saying so far it seems to be Hardcoded but if it isn't I too sure have the same question as you do. Right now this as I've stated appears to be the only work around.
posted on January 15th, 2019, 4:53 am
Try looking into the Aipdef.h file in the AIPs folder, find #define MAX_ELEMENTS 200, and just increase the number there to more than the number of lines you'll actually use. Seems to work well enough for me. :thumbsup:

Who is online

Users browsing this forum: No registered users and 3 guests