FO only sees my Intel integrated, not my Nvidia GPU

Program aborts? Network configuration? Graphic errors? Bugs? Post your question here.
posted on December 13th, 2014, 10:57 pm
Hi there. I checked the bug list and searched the forum but I couldn't find any references to the kind of problem I've been having. I have an MSI notebook which has integrated Intel graphics, as well as an Nvidia 840m graphics card. Fleetops runs, but I'm unable to select the Nvidia card in the graphics options menu. It only displays the Intel integrated option.

My Nvidia GPU comes with a utility which is supposed to let you force an application to use the Nvidia card instead of the integrated option, but it hasn't had any effect when I set Fleetops to use Nvidia. I've tried configuring both the fleetops.exe file in the root folder, and the armada2.exe file in the data folder to use the Nvidia card using this method, but it still only shows the integrated option in the graphics menu.

Any ideas or experience with this kind of issue? It's not the end of the world if there isn't a solution. I can still play it. It would just be nice to be able to run it with some AA and bump maps turned on.


EDIT: Oh and my drivers appear to be up to date.


silly gpu.jpg
silly gpu.jpg (208.59 KiB) Viewed 1127 times
posted on December 14th, 2014, 1:35 am
Hm. Weird, conversely I can only select my gpu and not the integrated graphics option on my desktop. Instead, I have my gpu twice in the dropdown list, one marked with (primary). I assume this is actually referring to the device which is displaying each screen.
posted on January 3rd, 2015, 8:35 pm
ive been having this same problem too. tried everything and cant get the game to recognise my geforce 860m card...
posted on January 4th, 2015, 9:45 am
same gt820
posted on January 5th, 2015, 9:21 am
Two things you could try:
- force optimus globally to use the nvidia card
- run a compatible program that is using the nivida card in windowed mode, then start FOPS and check if it detects it properly
posted on January 5th, 2015, 9:23 am
Forcing it globally doesn't work either

I'll try the second method tonight
posted on January 5th, 2015, 9:26 am
I thought so, but it's worth trying.

Optimus sadly has issues with some older directx games.
There's definitely other solutions to solve it, sadly no simple ones.
posted on January 5th, 2015, 9:32 am
What are the harder methods? I've tried disabling the Intel card but this only causes fleet ops to crash on startup
posted on January 5th, 2015, 9:46 am
kamikazi929 wrote:What are the harder methods? I've tried disabling the Intel card but this only causes fleet ops to crash on startup

Weird, back then just forcing the nvidia card worked nicely for me.
It probably crashed due wrong configuration - tried to access the HD, which you deactivated. You need to have a clean install / config in order to test such.

Sadly no Laptop here has Optimus anymore, so i can't really test it properly - sorry that i can't help you any better because of this.
So you basically have to google for "Optimus directx 9", and do some try & error.

Did the 2nd app trick work?
posted on January 5th, 2015, 10:51 am
Just tried with metal gear solid ground zero and fleetops still doesn't detect it
posted on May 21st, 2022, 2:19 pm
Last edited by lemieuxhelms on July 14th, 2022, 10:28 am, edited 1 time in total.
Did you figure out how to solve this kind of issue? I am currently struggling with the same booth rental Austin home renovation contractors near me Keller TX
posted on May 22nd, 2022, 8:53 pm
lemieuxhelms wrote:Did you figure out how to solve this kind of issue? I am currently struggling with the same booth rental Austin

I have the same issue and as far as im aware there is no fix. You just have to hope your integrated card is capable of running fleet ops. Thankfully my cpu is pretty powerful and has a decent integrated redeon gpu.
posted on May 24th, 2022, 6:58 am
I had the same issue. MSI laptop with 860m and only the Intel card was detected.

I just found a fix.

Go to:
C:\Users\"YOUR_USERNAME"\AppData\Roaming\Star Trek Armada II Fleet Operations

and edit FOData.ini

set m_displaySecondary to 1

Save and launch the game with the Armada2.exe

I had tried previously to force that exe to use the Nvidia GPU in the Control Panel, so I'm not sure if that's also a requirement.


Screenshot_1.png (317.74 KiB) Viewed 302 times

Who is online

Users browsing this forum: No registered users and 1 guest