Fix some ST:A2 AI issues ?

Program aborts? Network configuration? Graphic errors? Bugs? Post your question here.
posted on April 10th, 2021, 1:12 am
Hi I love ST Armada games, and so it's great to have FleetOps and the STA2 mod that allows widescreen, I remember hooking up an old 4:3 monitor to play it LOL.

In the STA2 mod I'm running, there's some AI that doesn't work like the original, and it's super annoying, and gaming breaking in some cases. If the mod was made this way, how do I change it? I'm even up for learning some programing to change this.

-Repair ships won't follow much of any orders, they are too dumb to track anything and use repair, or move to anything close by and repair it. Like trying to repair an orbital metal mining station, they won't move to keep up and repair it.
-They can be sitting near something like a turret, be set to Red level movement and special weapons, and still not repair it.
-If a vessel it at at different 3D elevation from them, they won't auto fly up/down to reach the ship, they just give up, and sit there, u have to make them guard the target, to get them to fly near it, them tell them to repair again of course, otherwise they often do nothing on their own.

The Klingon ships that launch boarding teams of warriors, not the troop transports with 500 crew, the cruisers with a little shuttle-pod they launch........those are supposed to track the enemy ships and do something, but in this STA2 mod, it doesn't work like it did in the original, or at all it seems if the enemy ship moves, and these little boarding shuttles are supposed to auto fly to targets, but they don't most of the time.

That's they main things that I remember ATM. Other than that, it works great I think
posted on June 2nd, 2021, 2:00 pm
which version of the a2 backport theres a few by different people
posted on June 2nd, 2021, 5:47 pm
Hi in the SFO mod menu it says STA2 classic v1.2b

I don't know very much programming, but is there guides out there or descriptions of how to get inside the game, and see what it's doing ?

In the version I have, on the Klingon mission the Unknown Prize, u have to drag a ship through a wormhole with the tractor beam, but it never works, the towed ship never get towed in. So I use the Kobiashi marruo cheat code to skip to the next mission.

Overall it works great, I've wasted way too much time playing this game, but it's a lot of fun.
posted on June 3rd, 2021, 12:30 pm
i think that might be my version sounds like possibly fleet ops changed something. not really messed around witht he AI much
posted on July 13th, 2021, 4:51 pm
As far as the repair ships, I have found that while they are moving towards the ship/station to be repaired you need to click on the ship/station. When the repair ship comes to a full stop it will not obey the order.
posted on July 20th, 2021, 12:14 am
I had this issue in my mod. I can't remember exactly what I did, but comparing the RTS.cfg file of mine with the Classic Mod either delete or comment out the line float REPAIR_SHIP_DISTANCE = 350; at the very bottom.

You could search through my thread from the Upgrade Project 2014 mod. I believe I posted about the issue in there then found what fixed it.

Who is online

Users browsing this forum: No registered users and 3 guests