Tryptic's Mod Version 4

I want my 15 rapid-fire quantum torpedo launchers Uber-Defiant now! - Get help from modders. Share your work. Discuss modifications.
1, 2, 3, 4
posted on January 17th, 2022, 7:29 am
Last edited by Tryptic on October 13th, 2022, 10:23 pm, edited 1 time in total.
It's here! I mostly post updates on the Discord channel these days, but progress is ongoing.

I released Version 4.0.0 around Christmas, but in my rush to get it out, I left a lot of bugs and crashes in the code. After a few weeks of cleanup I've just uploaded V4.0.5 which should be pretty stable.

The download link will never change, since it links to a folder where I swap out the files. I'll also start including a Changelog file in the folder, so you can check it out to see everything that's changed :D ... ptic's_Mod

EDIT: As of 10/13/2022, Version 4.1.6 is now available at the link above! Come check it out.
posted on January 28th, 2022, 11:29 am
Found two bugs in V4.0.6:

- it's crashing as soon as you try to build a torpedo, phaser or pulse turret. (fed)
- sometimes ships won't leave the shipyard when you order them to repair (fed)
posted on July 21st, 2022, 8:28 am
Bumping for the release of version 4.1.3.

This time I did a deep, deep pass over all of the Borg and Romulan code, optimizing and refactoring things. I believe I've caught all the bugs, but work is naturally ongoing.
posted on July 22nd, 2022, 11:41 am
Nice work, but... I've found a really annoying bug: The Newton class is useless now, cause it's not doing anything without a specific manual order. The automatic repair doesn't work anymore and the button is gone.
posted on August 3rd, 2022, 12:00 am
Sorry about that, I'm in the middle of a full testing pass and the Federation are last on the list, but I'll fix the Newton by the next version, I promise.
posted on August 16th, 2022, 10:25 am
There was a new version (I've already downloaded it ;) ) - but now it's gone. So I guess I shouldn't try the new version? :sweatdrop:
posted on August 16th, 2022, 6:23 pm
It's still available in the archive section...but it had a major bug. The Command bonus sets ship damage to 0 :sweatdrop:

I'll have another version in a few days with plenty of fixes.
posted on September 10th, 2022, 11:10 pm
Version 4.1.5 is complete!

Very little balance change in this one, mostly bug fixes and AI tweaks.
posted on September 13th, 2022, 8:58 am
The new version looks good! But the game now crashes after some time. In the past two games each time my streamrunners wanted to fire at an enemy ship - once against Borg, then against Dominion.


flops-crash2.jpg (141.29 KiB) Viewed 687 times
flops-crash.jpg (200.79 KiB) Viewed 687 times
posted on September 13th, 2022, 3:00 pm
Tried it again - when an enemy ship is coming out of the FOW and the Steamrunner is firing -> crash
posted on September 22nd, 2022, 4:13 pm
I just can't get this mod to work or the vanilla Fleet Ops.

I can get the Dominion War Mod to work perfectly - just wanted to add that in first.
I can also get the KA2 EAW Mod to work perfectly when loaded in as a mod on Fleet Ops Vanilla.

However, none of Trypic's mods work at all.
1) Running on a Vanilla Fleet Ops - crash on launch
2) I tried replacing some game files with the Dominion War Mod ones and can now get Tryptics latest mod to not crash on startup, however, starting any instant action game won't give me any control - just a rotating 'Error!' message on the star map at my starting position, with no control over my ships. I can scroll the map and see other AI players building but I can't do diddly.

Very frustrating as I really wanted to play a different mod, but looks like there's something in Tryptic's versions that won't work (Win 10 64 Bit).

So there must be something that is in these 2 mods above (filewise) that is not in the vanilla Fleet Ops that makes it work.
posted on September 25th, 2022, 4:56 am
So to clarify, you can't play Fleet Operations version 3.2.7 with no mods at all?

If this is the case, my guess would be that a security program is blocking one or more files from being installed in the first place. Tryptic's Mod probably doesn't change those files, and tries to load the original, while the other mods replace them with different versions.
posted on September 26th, 2022, 7:57 am
So hopefully to clarify:

Install of Vanilla Fleet Ops 3.2.7 will launch, but on any instant action game launch will crash with the usual fault.

If I instead load the KA2 EAW Mod and start an instant action game it works for a while and may crash at random times throughout the game.

If I install the Dominion War conversion as a stand alone install - I can play that straight away on any instant action game without any crashes whatsoever. I then tried to see if I could load another Mod from within DWM and could get Tryptic's latest Mod to load, set game options and launch - but as said only the AI players are working - no control of human player.

So as things stand I'm limited to Dominion War Mod at present.

I was just making the point that there must be some key files in DWM that are not in the Vanilla Fleet Ops that make it work.

1) I should also say that I have tried all the compatibility options to no effect (including applying these to the Armada2.ldl file with no difference so defaulted compatibility back to none.
2 Have changed the FODaya.ini to both D3D9=False and True - which made no difference either on the Vanilla version.
3) Also copied a Win 7 install of Fleet Ops (as also mentioned on the Forums) over and no difference at all.

I think I'll just have to stick with the DMW as that at least works, but I'd love to know what it is that makes this work and the vanilla not!

Thanks for reading anyway.
posted on September 26th, 2022, 10:08 am
Yeah, that's really weird. I don't know enough about the Dominion war mod standalone install.

It is possible that the crash is being caused by a bad config. I've seen the game crash in such a way that it leaves a bug in the config files, and after that it will keep on crashing until you go in AppData/roaming and delete the right files. It's certainly worth a try in this case.
posted on September 26th, 2022, 12:43 pm

Yes, tried all that and deleted everything in that folder to eliminate corruption / config problems and reinstalled everything from scratch to recreate them.

What is odd is that I can go from running an instant action game in the vanilla FO, which crashed immediately launching, but I can exit that and run Dominion Wars Standalone perfectly well, so this tells me there has to be something in the DWM files that my system likes! :D

Shame as I was itching to give your mod a go! :(
1, 2, 3, 4

Who is online

Users browsing this forum: No registered users and 1 guest