Need help with sigma mod!

I want my 15 rapid-fire quantum torpedo launchers Uber-Defiant now! - Get help from modders. Share your work. Discuss modifications.
posted on April 17th, 2019, 12:09 am
Hello! This is my first post on this forum

I got armada 2 recently after learning that a game developer I follow the UndyingNephalim had a mod for this engine that I decided to check out named sigma. While he abandoned it a while ago I still wanted to check it out so I downloaded it. I followed the instructions to make it work and it crashed on me when I start it up. The odd thing is that an older version works perfectly. I do not know exactly why it did that but looking on the forums I think it is about the ODF.fpq file. I replaced the ODF.fpq file with another one from this part of the forum and I looked at Blades onedrive file on page to but it has apparently vanished. the replaced ODF file caused the same thing which was a crash before the thing even got to the starting menu. I tried replacing the ODF with the ODF from both the ODF from the old sigma and fleet ops itself and nether of those got what I wanted. with the one from fleet ops I got a copy of fleet ops and with the old sigma I got the demo. I also tried to edit the file with FQP edit but It would not open any ODF files besides the old sigma for an unknown reason. Can anyone help me out?


what happens when I try to edit the ODF file from the orignal
Capture3.PNG (99.18 KiB) Viewed 962 times
crash on start up with the ODF that came with the mod
Capture2.PNG (244.94 KiB) Viewed 962 times
picture of the two mods I have for fleet ops
capture1.PNG (236.28 KiB) Viewed 962 times
posted on April 17th, 2019, 5:13 am
The SIGMA game mod works just fine installed in the Mods folder of the FO Ver 3.2.7. I played a few years ago from Windows 7 and 8.1 .I never had any problems.
Also you can give a try with that Sigma demo for ST Armada 2, but I had a few crashes on it,maybe from the demo itself: ... 05/details
posted on April 18th, 2019, 5:25 pm
Okay I reinstalled feetops and then the sigma mod. The sigma mod intro and menu worked like normal but then when I tried to go to a custom battle the loading bar got more then half way across before it crashed. I got a bug report but I do not know what it means or how to solve the crash. It has been happening every time I try to start any type of battle using the mod.


the bug report that came with the error.
Capture6.PNG (49.69 KiB) Viewed 934 times
the error screen after the loading stops
Capture5.PNG (22.38 KiB) Viewed 934 times
the menu for the mod
Capture4.PNG (481.73 KiB) Viewed 934 times
posted on April 19th, 2019, 7:37 pm
You want to check the section of the Bug Report that say: "Call Stacks" and "Stack Dump". Sometimes "Stack Dump" even lists the offending file.

What you have posted in screenshots will not help at all to solve any crash for anyone. Every time I get any crash I always go to: "Call Stacks" and "Stack Dump" only.


Plus your out of date version needs to have the FleetOps version number updated in its info.ini file. Most likely increased to the current version of FleetOps.
posted on April 19th, 2019, 10:48 pm
Thank you for the instructions. How do I read these bug reports?


third part of call stacks
Capture9.PNG (43.56 KiB) Viewed 910 times
second part of call stacks
Capture8.PNG (42.52 KiB) Viewed 910 times
first part of call stacks
Capture7.PNG (43.58 KiB) Viewed 910 times
posted on April 19th, 2019, 10:49 pm
Stack dump is here because it only allows three attachments


stack dump
Capture10.PNG (41.51 KiB) Viewed 910 times
posted on May 11th, 2019, 2:38 am
Sorry about getting back to this late; been very busy. I've been trying to figure this one out but honestly I'm stumped. Might be related to the version of FleetOps you're using or not. I believe the Sigma Mod was only for FleetOps Version 4.0.0 that technically was never completed. There's a loader that terns Version 3.2.7 into 4.0.0. You might want to check what Version of FleetOps you're using.

Not sure what this problem is though, the Bug Report isn't showing any of the clues I'm personally able to figure out.
posted on May 17th, 2019, 8:35 am
It's been so long that I can't remember. I did indeed have a version of Sigma for the 4.0 version of Fleet Operations that never came out. Sadly I don't have the Fleet Ops related files for that. I'm pretty sure the version of Sigma I released on moddb was for 3.2.7 though. ???

EDIT: I actually do have the 4.0 version of the Fleet ops exe after all these years, I'll attach it here, maybe that will get it to work for you.

(180.63 KiB) Downloaded 222 times

Who is online

Users browsing this forum: No registered users and 2 guests