MOD: STA2 Upgrade Project 2014 - A stock A2 mod in FO

I want my 15 rapid-fire quantum torpedo launchers Uber-Defiant now! - Get help from modders. Share your work. Discuss modifications.
1, 2, 3, 4, 5, 6, 7 ... 29
posted on January 15th, 2014, 5:44 pm
your mod would be the only one I had. I had no mods folder beforehand. I'm using windows 8 if that helps at all
posted on January 15th, 2014, 6:04 pm
rifraf wrote:Perhaps someone with more technical expertise can assist? My mod is a standalone mod so clicking something in my mod shouldn't have any effect on FO or another mod that is unrelated. It's basically stock A2 ported into FO just like the original Classic Mod. They are separate entities.

When I looked at %appdata%\Star Trek Armada II Fleet Operations\FOData.ini to see about how the team color setting worked, it seemed like a lot of settings were saved in a single file and shared globally rather than being on a per-mod basis. It's possible that if a toggle button was hit at one point or another and the FO team removed the toggle from their interface you could have to go back into the mod to switch it back.
posted on January 16th, 2014, 7:30 pm
um..sooo unless im completely crazy..which might very well be.. Where is Regula II in the first Federation mission? Ive explored the entire map..and eliminated all Borg.. but theres no planet by that name on the map.. I know its supposed to be there.
posted on January 16th, 2014, 7:44 pm
Not crazy. It was a mistake on my part when I was redoing all the maps. I deleted the planet and just placed a new one not thinking of the consequences. Someone noted it back on page 2. It'll be fixed in the next version when I redo all the maps again.

@Cabal. That's a great find with the shared files thing. I'm hoping this is the answer to the issue with Spartan and Rickr. Sounds like Spartan got his fixed, but anyone else have this/fixed this?
posted on January 16th, 2014, 9:44 pm
rifraf wrote:Not crazy. It was a mistake on my part when I was redoing all the maps. I deleted the planet and just placed a new one not thinking of the consequences. Someone noted it back on page 2. It'll be fixed in the next version when I redo all the maps again.

@Cabal. That's a great find with the shared files thing. I'm hoping this is the answer to the issue with Spartan and Rickr. Sounds like Spartan got his fixed, but anyone else have this/fixed this?


Got ya..wheewww and Ive made some modifications to the weapons for appearance sake. And some of the ship stats..
I know the goal is to make this as close to the original A2 as possible..but the way game launched..ships were destroyed waaaay too easily. Id like to show you some of the changes ive made (been doing this modding thing a loooooong time)
posted on January 22nd, 2014, 6:16 pm
Could somebody please post a 1920x1080 GUI-less screenshot of the mod?

EDIT: I have a new GUI update for you. There is a basic button border mock-up on display. The buttons themselves would be on a square grey background and the borders would complete the shape and have a colored glow denoting if the weapon is defensive, offensive, or neither. Different factions would have different corners and such; rounded for Feds, chamfered for Klingons, etc. Due to the system, buttons for construction, orders, AI, etc. would need to be remade for each faction, but they could blend in better than the special weapons. Buttons from left to right: construction/command, defensive special, offensive special, neutral special.

gui2.png
gui2.png (464.73 KiB) Viewed 484 times
posted on January 22nd, 2014, 9:42 pm
I like it. Very cool looking. And with different looking corners to differentiate race will be a nice touch. The different glows for different buttons is an awesome idea. I can check on posting a pic you requested when I get home from work too if you still need it.

I was going to implement new command buttons by Tain_Enabran from here:
http://armada2.filefront.com/file/Gener ... ent;112787

They are slightly transparent black and look really good. I can get you one of the actual buttons when I get home if you like? Would I still be able to use these as you stated they would need to be remade?
posted on January 22nd, 2014, 10:35 pm
Sorry for DP, but I guess the buttons I mentioned won't work. Duh. Didn't realize what you were saying when I first read it. My bad.
posted on January 22nd, 2014, 11:04 pm
I could use them, they would just look odd with the others. I could make the buttons more like them, though.
posted on January 23rd, 2014, 3:01 am
No, I don't have to use them. I used them in my personal install and really liked them so thought they'd look great in the mod. After I got permission I stuck them in and was going to have them in the next release, but I don't have to. I never thought about them not fitting with the work you're doing until you mentioned it.

I really like how you did your buttons with the different glow for different action/meaning. I was just thinking it would be a lot of work (unless you know of some really easy way) to add all the pictures to the new button style you make. I would rather see what you come up with as you progress as well.

Here's the 1920 x1080 pic you wanted. I did two

Attachments

FOScreenShot_140122_194821.png
FOScreenShot_140122_194821.png (919.09 KiB) Viewed 447 times
FOScreenShot_140122_194904.png
FOScreenShot_140122_194904.png (821.94 KiB) Viewed 447 times
posted on January 24th, 2014, 2:53 am
I have another bug I have to report. Enemy Ships are disappearing when entering nebulas other than the purple ones (don't remember the name) Its the nebula that disables sensors and slows ships down. I just finished the Federation campaign and I had borg weapons fire coming out of nowhere. I couldn't target anything then the ships would appear like they came out of a nebula. As far as I know this is only supposed to happen with the purple nebulas but it was happening with the radioactive nebulas too. And the enemy ships weren't completely in the nebula either they were very close to it.
posted on January 24th, 2014, 5:12 am
Last edited by rifraf on April 24th, 2014, 6:40 pm, edited 1 time in total.
That's certainly one I've never heard of. If it's happening on a radioactive neb are the ships taking any damage? I didn't edit any of the nebs on maps except to actually delete some of them since they are stacked together too much (too deep/high)

I'm attaching redone single player maps that I did to correct mistakes from the first time. Try them and see if it still happens. I feel useless as I don't have these bugs that seem to be one-offs for others so don't always have an answer. I keep working on the next update though so will see if I come across anything.

I'm actually redoing all maps for a third time for one of the next updates so will keep my eyes open.

EDIT 4/24/14: I removed the maps originally included in this post as the most up to date maps are in the first post with the main download.
posted on January 24th, 2014, 11:23 am
As far as I can tell they are taking damage from the nebula but my ships/stations can't target them. but sometimes they disappear even if they are very close to a nebula. They also disappear with Metreon Nebulas as well. I know they take damage from those.
posted on January 26th, 2014, 11:40 pm
I double checked and the Mutara and Cerulean nebula's are the only ones that have the settings setto hide anything inside. That's the stock setting and I've never edited any of them so it must be a glitch if the big radioactive nebula is doing it too?

Questions is what is triggering it to happen? I'll keep digging.
posted on January 27th, 2014, 4:50 am
I don't know what could be triggering it, but your redone single player missions seemed to work that problem out. I wanted to make one other comment I don't know if anyone else has said anything but the navigation in this mod seems to pale in comparison with even Stock A2. I get your reason for slowing down warp drive, but whenever I order a full fleet to a location, 1. It takes forever for the ships to arrive they seem to take the longest route to get to a location and sometimes head in the opposite direction before turning around and 2. They end up in a sheet formation and depending on the size of the ships in question they can be very spread out making it hard to move the fleet through maps with lots of asteroids or planets/black holes etc.

On another note I've already added some ships to this mod, I want to try and get the AI to build them in the single player missions but have no idea which files I should add the ships to. For the feds I have two different Excelsiors, an Ambassador a Galaxy refit (not the Galaxy-X) and the Excalibur. The Klingons have some additional ships and I plan to add some Cardassian and Borg ships as well. Any suggestions?
1, 2, 3, 4, 5, 6, 7 ... 29
Reply

Who is online

Users browsing this forum: No registered users and 2 guests

cron