Fleet Ops Roots 4.0 is now available.

I want my 15 rapid-fire quantum torpedo launchers Uber-Defiant now! - Get help from modders. Share your work. Discuss modifications.
1, 2
posted on February 10th, 2024, 5:15 am
LogicMage3 wrote:I noticed FO 3.2.7 as sub mod. Does the vanilla armada 2 3.2.7 mod work with 4.0.0?


The A2 Classic Mod does work with Fleet Ops 4.0 in general, pretty much out of the box actually*. For Roots though there is currently a glitch that causes crashes/freezes for about 2/3 of the A2 Classic Mod's single player missions. I did track down the issue and have fixed it but that will be in the next upload, probably in a couple of days, that also changes the movement autonomy system to something more useful (no more babysitting your ships). The A2 Classic Mod does have 800x600pixel shell menu assets (bitmap folder), so that looks ugly with Roots' 1200x900 menus, but it will work and someone could manually scale up the bitmap pictures.



*To get rid of the warning that says the mod is too old make sure you have AssetVersion=40000 in the info.ini for the A2 Classic Mod.
posted on February 10th, 2024, 6:56 am
Okay that new version is now online and I've tested it with the A2 Classic Mod as a sub mod and that runs fine, except for that shell menu size mismatch.
posted on February 10th, 2024, 6:36 pm
Hey @JanB -- very excited to try this out, but running into an EAccessViolation error upon completion of a mission/instant action loading screen. Any ideas? I'm running on an M2 Mac via Parallels w/ Windows 11 so there's a lot of layers of emulation going on; vanilla (GOG) Armada II and FO 3.2.7 both run fine (the latter after manually replacing Armada2.exe with the one from the GOG folder). Is there something different about yours vs. regular FO that would cause a crash? Have tried all the compatibility mode options, high DPI stuff, even some of the DX9 wrapper apps; nothing seems to get past it. Appreciate any advice you might have! Bug report attached.

[Edit] I should say, FO 3.2.7 loads fine by itself as a separate instance; when loading it via the Roots launcher, it also crashes.

exceptArmada2.txt
(29.79 KiB) Downloaded 7 times

Screenshot 2024-02-10 at 1.41.23 PM.png
Screenshot 2024-02-10 at 1.41.23 PM.png (1.26 MiB) Viewed 209 times
1, 2
Reply

Who is online

Users browsing this forum: Yandex [Bot] and 4 guests

cron