Won't install on Windows 10?

Which race do you like most? What do you like - what you don't like? Discuss it here.
posted on August 10th, 2018, 2:25 am
I have a clean disk for Armada 2. My rig is a windows 10 pc with well over the recommended specs for the game lol. I click the Autorun file and the installer opens up and I am allowed to click the button that says "install" I do but after a couple seconds the installer vanished and nothing ever happens. I try to set it in compatibility mode and none of the options work. So the question is can I actually get the base game to install from the disk on windows 10 and also do I even need to install the base game or can I just download and install Fleet Ops and it will work?


Desktop Screenshot 2018.08.09 -
Desktop Screenshot 2018.08.09 - (1.1 MiB) Viewed 2351 times
Desktop Screenshot 2018.08.09 -
Desktop Screenshot 2018.08.09 - (1.02 MiB) Viewed 2351 times
Desktop Screenshot 2018.08.09 -
Desktop Screenshot 2018.08.09 - (1.11 MiB) Viewed 2351 times
posted on August 10th, 2018, 2:14 pm
If you are trying to install fleetops, you can just run the fleetops installer and it will install if you tell it to look for an armada CD in the drive rather than an install .exe
posted on August 10th, 2018, 4:15 pm
I am also trying to play any form of Armada on my Microsoft Surface Pro 4 or Surface Studio because I want to try the touch screen on this RTS. I haven't seen any recent posts so wanted to see how to play Armada 2 on Windows 10. I installed Fleet Operations Version 3.2.7 and unzipped the files into a folder. Now in the folder I clicked the Fleet Operations icon and it opens the main menu. I cant play instant action or any mode for that matter because it states I need my own cd.

Even the mods folder I made that contains STA2 classic file shows up on the mods settings but it still requests the cd. I tried running the compatibility mode on the specific Armada.exe file and the screen resolution will change along with a brief sound from the game but it will not load.

Edit 8/10 1900

Well I ordered an external disk drive to try and install the original cd. Tried like hell to try and install the program but the 32-bit installer keeps crashing and the demoshield that assists in the installation does not work. However I went right back into installing the Fleet operations and I am very excited about the initial game especially the Dominion War MOD. Its a much more simplified version of the game. Im not sure if it is possible to play the full version of the game on the windows 10 platform but the touch screen feature on my surface studio works wonders.

It satisfies my Star Trek RTS hunger.
posted on August 11th, 2018, 2:59 pm
you should be able to make an ISO image of your Armada 2 - CD and use this: http://wincdemu.sysprogs.org/

@4koptiks I attached an image of what you should look for when setting up FO. I still think you can also install A2 if you navigate to the folder in the attached image and press "setup.exe" and are hoping to play that too, you will just need to find the patches and stuff once base game is installed.


if you navigate to here it should also let you install. Just takes 10-15 min sometimes to launch from my experience
A2.PNG (54 KiB) Viewed 2312 times
Optical.PNG (122.8 KiB) Viewed 2312 times
posted on August 12th, 2018, 4:23 pm
Yes I did attempt to make an iso image but there were bad sectors on the disk. The image completed but I ran into the same issues when trying to initiate the autorun/setup utilities. Was unable to install it however I am able to still play the various mods from Fleet operation. The thing of it is some mods will not work without the disk. I need the disk and the software to make the Dominion War Mod work which made it all worth while.

Love playing Sacrifice of Angels and Call to Arms on TV while assembling my large Armada with Sisko's Defiant at the helm. The miranda, excelsior, and centaur classes are especially nice. You can even have them patrol and flew by the Station like the episodes. Brought back a lot of memories along with the music, additional races (Dominion and Breen were impressively done) , descent AI, and audio Dominion War Mod is the go to game if you are an ArmadaII/DS9 fan.

Anyways Fleet Operations is possible to play on Windows 10/ Surface gear and the touch screen option works with no issues. You can play the STA2 mod without the disk. Its a "classic" form of the game but not the actual game itself with the campaign missions, etc. Other Mods like the Dominion War I need the disc to make it work. As for the actual game itself I haven't lost hope.
posted on August 12th, 2018, 9:00 pm
Hey All,

I play FO, tryptic's mod 3.0b

Windows 10

I have had issues installing on firends PC's - all works fine now.

The main thing that came up was anti-virus softwear. Loads of stuff hates fleet ops. Macafee is a total no go.

As such you may need to allow it through.

Tryptic has a disk image on his file share so you may be able to take that... I have one too.
posted on August 13th, 2018, 11:17 pm
I have had similar issues with both Windows Defender Firewall (though usually not on install) and Ad Aware.

Ad Aware will stop many installs, especially those which do not save savegame files to the documents folder. This includes A2.

I have also had issues with both Armada2.exe, and fleetops being flagged as dangerous malware by AdAware.
posted on August 17th, 2018, 2:54 pm
I am playing Armada 2 on Windows 10 Microsoft Surface Studio. Touch screen, video, audio, missions, and instant action all work.

The only way I could install it was to create a virtual machine with windows xp. Install the game there and then transfer it to the shared drive along with your host computer. When you launch the game from there everything works perfectly.

I tried this method for Armada 1 but was unable to get it to work. Used another method to install Armada 1 but the games will still install and play.

Armada 1, Armada 2, and Dominion War mod - Must haves for any Star Trek RTS fan from Next Generation, DS9, and Voyager.
posted on February 3rd, 2019, 5:19 am
I recently got a new computer and I searched on how to get A2 to install on my Win10 PC (since I had such a hard time getting it to run with Win8) and saw many different scenarios to try. I did all of this before even putting the disc in. Then, after all of my searches, just put the disc in to see what would happen. It installed just fine and seems to run fine as well. Is this a fluke? Am I going to run into issues later on? I will say that the resolution is a bit off from what I remember (it's been over 2 years since I have played). I started a single player campaign and all seems well. I do remember with the Win8 setup, I had to DL a few patches to get it to run and was happy with the results, aside from having to disable McAfee during the startup.

Who is online

Users browsing this forum: Bing [Bot] and 4 guests