Trying to play single player campaign in armada 2 classic

Which race do you like most? What do you like - what you don't like? Discuss it here.
posted on May 27th, 2019, 5:05 am
I'm sure this has already been answered, I've tried searching but couldn't find this exact issue.

I'm trying to play the single player campaign for armada 2. Here is where I am stuck.

-- Found old armada 2 disk
-- Installed Fleet ops
-- Found the armada 2 classic mod
-- Made the Mod folder, unzipped the mod into the folder
-- Launched FO, launched the mod....

I'm at the main title screen however, I haven't found any way to access the single player missions. No button on the main menu, nothing in options etc. Is it in the instant action menu? It almost looks like something is missing above instant action...

I'm sure I'm just doing it wrong, can someone offer some guidance?

Thanks All.

Attachments

armada2menu.png
Here is my menu.
armada2menu.png (292.38 KiB) Viewed 452 times
posted on May 27th, 2019, 1:29 pm
Double check to make sure that you're using the current versions of both Fleet Ops (3.2.7) and the Star Trek Armada 2: Classic mod (1.2b), as the missing Single Player button, and other missing or incorrect details, would suggest one of the two (if not both) are outdated. I've attached how the menu should look, for reference.

I also suggest opening up the classic mod's RTS_CFG.h in a text editor (Notepad works fine) and searching for this line:
int cfgSINGLE_PLAYER_ENABLED = 0;

and changing it to
int cfgSINGLE_PLAYER_ENABLED = 1;

which should enable the Single Player button, and thus allow access to the Single Player missions.
If int cfgSINGLE_PLAYER_ENABLED = 0; isn't listed in the file at all, then your version of the classic mod is definitely outdated.

Attachments

Armada2ClassicMenu.png
How the menu should look.
Armada2ClassicMenu.png (161.14 KiB) Viewed 443 times
posted on May 27th, 2019, 3:09 pm
Thanks for the reply, I didn't have the rts file in the mod you were talking about. I found another link, downloaded and boom it works! Thanks so much!

Have a great day.
posted on May 31st, 2019, 11:59 am
Last edited by Guest_8472 on May 31st, 2019, 5:22 pm, edited 1 time in total.
I'm working my way through the single player mission and have hit a snag. In mission 15: Klingon/"Unknown Prize," I can't tow the disabled "singularity ship" through the wormhole. The tractor beam just lets go every time the construction ship goes through. Is there a workaround for this or am i doing something wrong?
posted on May 31st, 2019, 4:49 pm
To my knowledge there is no workaround. I found this while working on the Upgrade Project mod when I edited the maps. I tried the stock map and it too had this issue.
Reply

Who is online

Users browsing this forum: No registered users and 4 guests

cron