stock a2 texture issue/question

Talk about anything related to old versions of Armada.
posted on February 12th, 2013, 1:25 am
I have an issue with a model of the original byard2 taken from A1 and converted to A2. Here's the mod: http://armada2.filefront.com/file/NewOld_Yards;3520

MAP also used it in his Borg Incursion 2 mod, it's the claw looking yard.

Anyway, I want to change it's texture so I choose a different borg texture from anywhere, rename the .tga to match the texture that came with the mod, however viewing it in the 3D viewer or in the map editor the model looks half invisible like the new texture I used is incomplete. What would cause this as it's just a texture? Shouldn't the texture cover the model fully just like the texture that came with it and is assigned to it in the .sod?

Looking through old A2 forum posts I found this: Usually a transparent object means the textures have lightmaps when the mesh isn't properly set to handle them. Could this be the reason?

Regards and Thanks
posted on February 12th, 2013, 1:39 am
Probably is the problem, A1 models don't normally use lightmaps. Ones converted to A2 don't always have them added, either.

One way to test it would be to add a random lightmap to the original texture and see if the same problem appears.
posted on February 12th, 2013, 11:41 pm
this could be down to so many things... Alpha channels can't set transparency so making those parts invisible. The model could be looking for map points on the texture that just don't exist at all so have nothing to map. LIghtmaps and so on... Generally not a good idea to just replace a texture on a model but rather import the old A1 model and then export it again with the texturing mapping redone
posted on February 13th, 2013, 12:59 am
Thanks for the replies all. I notice when I install his mod to begin with that the texture is already incomplete or has blank spots all over where nothing shows so he must have an incomplete texture to begin with or set it up incorrectly? I gave away my copy of A1 years ago as I never liked it. Wishing I hadn't lately so that I had it for reference/ideas.

I am also lacking in modeling/texturing skills, never tried it so still in the asking questions phase. I downloaded milkshape 1.6.5 I think from old downloads at A2 files and got GIMP recently but haven't tried them yet. Working my way there.
posted on February 13th, 2013, 9:22 pm
As Tyler has said lightmaps seem to be your problem, try a texture without lightmaps and see if that fixes your issue. Failing that it could be the strings on the texture names, then you'll either need to hex edit it or import it which isn't possible unless you have the publicly unavailable importer.
posted on February 14th, 2013, 3:05 am
I've installed GIMP but when I try to install the TGATool2 from this site in the modding section of the guide it says it's not compatible with my x64 edition of windows. Does anyone know which program I can use that is x64 compatible?

Also, do all textures have an alpha channel? It says GIMP won't show them so how would I know if a texture does? I guess obviously most the mods (ships) I've dowloaded have glows when in the dark so they do but I'm sure some older ones don't.
posted on February 14th, 2013, 4:15 am
Run tgatool as admin. :) Should clear the problem up.
posted on February 14th, 2013, 5:27 am
Thanks for the tip but I right click the setup and click run as admin to install it but it sill terminates stating not compatible with x64 version even though the notes say compatible with all versions of windows.

On a side note I found a Borg texture in one of my installs from some mod years ago that works perfectly on the "new/old borg yards" mod for A2. Fully textures the model with no gaps or anything so that's good.

I dinking around the GIMP and see I can creat alpha channel. I goggles how and will try following that. Will creating an alpha channel in GIMP be the equivalent of any other program?
posted on February 14th, 2013, 6:55 am
Huh, running as admin fixed it for me. Maybe try compatibility mode too?

As to the alphachannels, the one in gimp is just transparency. There is a toutorial on filefront about how to do it in gimp, but it is very complicated. If I were you, I'd try to get tga tool to work before attempting it.
posted on February 14th, 2013, 4:20 pm
I did also try compatability mode and that didn't work either. I just have the setup in the public shared folder on my C drive. May have to try putting it on my desktop and see if that works running the setup from there?

From what I read in the guide here about the tga tool it sounds very simple so yes, I really want to go that route.
posted on February 14th, 2013, 4:26 pm
It is also possible that you have a different version of the TGA tool. I seem to recall there being one that doesn't work, so to save you the trouble of finding the right one, I have attached the one I installed in case you do have the wrong one. :thumbsup:

Attachments

TgaTool2.zip
(224.93 KiB) Downloaded 207 times
posted on February 14th, 2013, 4:34 pm
Awesome, thank you. Will try after work today. Want to be home trying now but work is always in the way of my personal life. :lol:
Reply

Who is online

Users browsing this forum: No registered users and 1 guest