New SOD Exporter for 3DS Max =ALL VERSIONS=

Talk about anything related to old versions of Armada.
1, 2, 3, 4
posted on August 12th, 2013, 5:11 am
I have 3DS Max 2013, but it doesn't seem to wanna export the model, even after doing the usual stuff that 2012 had me do to export. (Such as using the smooth function)

Is it possible for you to see whats wrong with it, or are you not able to?
posted on August 12th, 2013, 11:21 pm
I can have a look at the 2013 version file. I have access to 2013 now. Send to TPankov (at) (yahoo) (dot) ca

Cheers
posted on August 13th, 2013, 4:29 am
At this point, I cant. :blush:

I downgraded to 2011, which I know works. All the files that I had with 2013 have been downgraded as well. :-\

Personally, Max 2013 is stupid. Many good features were missing. :angry:

Oh well. Thanks anyway. :sweatdrop:
posted on August 13th, 2013, 2:23 pm
lol, ok. No problem. If exporter works in 2011, I'm happy. Guessing 2013 did something unexpected with materials without telling you about it. Materials is the one area where so many things can go wrong, that almost all problems in the exporter were in materials read/write.
posted on August 13th, 2013, 5:21 pm
Tell me about it. :hmmm:
posted on August 19th, 2013, 12:31 am
Hey, is it possable to make an importer for SOD models?
posted on August 28th, 2013, 10:53 pm
I'm having some trouble with bump maps.
I have some weird black lines all over my Sovereign when zoomed out to maximum height.
FOScreenShot_130829_005000.png
Zoomed out
FOScreenShot_130829_005000.png (159.16 KiB) Viewed 720 times

The black lines do not appear when zoomed in.
FOScreenShot_130829_005004.png
Zoomed in
FOScreenShot_130829_005004.png (1.21 MiB) Viewed 720 times

What is causing this?
posted on August 29th, 2013, 12:35 am
Do the lines flicker and change as you zoom in-out?

This is caused by a phenomenon called z-fighting. Occurs when two or more polygons are insufficiently separated in space and are overlapping in the field of view.

There are many algorithms that game engines use to overcome this error, but most are unfortunately computationally heavy. An older game like Armada doesn't use a particularly good algorithm, so we have the rater severe z-fighting error on models that have "layers" of polygons on top of one another.

One solution is to avoid the use of multiple layers of polygons when creating your models. This can increase model complexity and add to poly count, but the end effect is a much neater and cleaner model at all zoom levels.

Another solution is to use LODs for the zoomed out models that do not have the poly layering. At higher zoom out, you may not need the detail anyway.

In A1 there was a workaround that helped in some situations. You could force the topmost layer of polygons to do proper sorting (ei, resolve z-fighting) by assigning an "alpha" blending mode to the polygons. This did not work in A2 to my knowledge, but let me know if you want to try it anyhow. I'll explain the steps.
posted on August 29th, 2013, 1:02 am
By turning off bump maps in the graphic options the black "stripes" are completely gone and the model looks nice and smooth. I have created 4 lod's in the model and 4 for the textures and all are working correctly. If you want I can email you the .3ds and the textures so you can take a look yourself.
posted on August 29th, 2013, 3:16 am
Sure, interesting problem. Please email to tpankov (at) yahoo (dot) c a.

EDIT: sorry, posting from my phone didn't work right. I didn't even hit submit, and half of my post got posted anyhow.

I'm not sure why bump maps can cause this. On the screenshot it does look like z-fighting. I'd really like to look at the model and see what's going on.

Cheers
posted on September 2nd, 2013, 3:56 am
Took a while to track things down, but it does look like this is just a case of z-fighting between adjacent layers of polygons.

The problem is not related to the exporter script as the same issue can be seen with SODs exported with the original plugin in 3dsmax5.

What I found unexpected is that turning off bump maps, or removing them entirely from the material almost entirely removes the z-fighting. Also, I'm getting severe z-fighting on an older laptop with a NVIDIA GeForce Go 6150 card, but not with an NVIDIA GeForce 8800 GT card. This makes it rather unlikely that a parameter in the SOD file can fix the problem.


Several solutions are possible, however:

1. remove the underlying layers by "cutting" out the polygons. Adds a lot to poly count. Also may become time consuming. However, very clean results are possible, eliminating the z-fighting issue entirely.

2. use a single texture map across all layers. This way the z-fighting is not as visible since the same color pixels show regardless of which layer is shown.

3. don't use bump maps where you are seeing z-fighting issues. Detach the offending polygons as a separate mesh, and apply a duplicate material without the bumpmap. I haven't tested this, but should work based on what I've seen.


Now the question is, is it possible to configure the number of z-buckets available for z-sorting? Or is this something that hardware takes care of. Would love to have a nice solution, but afraid can't think of anything that I can do on the side of exporting the models.

Mr. V
posted on September 2nd, 2013, 5:11 pm
Problem solved. I deleted all underlying layers that created the z-fighting on the saucer section.
posted on September 2nd, 2013, 7:53 pm
Excellent :) Glad you got that taken care of.
posted on April 25th, 2014, 1:48 am
I can't get the download link to work. Everytime I click on it is says 'File not found' on the site :(.
posted on April 25th, 2014, 3:59 am
Thanks for letting me know. Updated the link to a mirror on the fleetops guide. Cheers

Guide and download here.
1, 2, 3, 4
Reply

Who is online

Users browsing this forum: No registered users and 2 guests