AI formation crash

Talk about anything related to old versions of Armada.
1, 2, 3
posted on January 10th, 2024, 12:38 am
SPARTAN078 wrote:I think I've tried installing vanilla ultimate over the classic mod before but it just made everything worse. I'll try again. I have the installer for vanilla ultimate 2.0. Unless there's a newer version.


Vanilla Ultimate has no problems OTHER than the ones that are stated in the Known Issues in the ReadMe.

It sounds more likely that you don’t understand how to correctly mod the game! You NEVER install an installer over the main game! You install to a separate location then copy things over after checking them over for errors in the files that can be missed. Plus FleetOps Mods Directory requires you do certain work as well prior to transferring a mod. Certain files have to link to FleetOps and you also need to have files referencing these FleetOps files.

Before you end up ruining your copy of the Classic Mod next I strongly suggest you copy it and rename the copy. Then install Vanilla Ultimate 2.0.0 (it’s the last copy of that mod for it’s completed and not broken other than their known issues). Check each file over then edit the corresponding file in the Classic Mod.

The Guide explains how to Transfer Stock Armada II in this way: http://guide.fleetops.net/guide/modding/tutorials/convert-from-a2 and how the Mods Directory fully works: http://guide.fleetops.net/guide/modding/modmodules.

Or you can outright 100% destroy FleetOps proper by deleting the ODF FPQ File. Copy over the ODF Folder, then Delete the SOD Folder (by removing the FleetOps ships and stations from it) Delete the Admirals Log Shipimages. Then do the same with FleetOps textures by ONLY removing their ships, stations, weapons and map textures. Certain textures are needed along with SOD files. Certain Main Directory files can be over written and replaced though.

As I’ve said my modding partner and I have this as a base for our mod. We totally removed FleetOps. The ending result is Armada II Classic WITHOUT FleetOps but when launched it’s still going to say on the game “FleetOps”. We have this done through the FleetOps Version 4.0.0 Loader though for certain features only there including how it’s supposed to bring the Trade Menu back but that’s not working. We don’t have a download setup of this but one can be made and made available utilizing the 4.0.0 Loader in a few hours. From there it’s just like modding normal stock Armada II without the FleetOps hassle of modding it and having what seems like fifty to a hundred ODF files to edit.
posted on February 6th, 2024, 1:22 am
SPARTAN078 wrote:I think I've tried installing vanilla ultimate over the classic mod before but it just made everything worse. I'll try again. I have the installer for vanilla ultimate 2.0. Unless there's a newer version.


Good evening Spartan078. It's been a while since I've been here so thought I'd check things out. I'm sorry you're having issues with my mod. Are you still experiencing them? I can try to offer some help depending on where you are with the mod, where you want to start based on the issues you're having? I'll keep checking back here.

I let Mega go unmonitored for years so all the links to my mod are dead. I still have them all and should probably renew at least one link to the full release of the mod.
posted on February 6th, 2024, 2:35 am
Actually, I got some help over on the Fleet Operations Discord Channel. It turned out to be a problem with the "new default.aip" file. I replaced it with the stock version, and that seems to have solved the issue. I was also having issues with the Borg requiring latinum for planetary shields but I ended up removing the latinum requirement from that and any race that used it for research. I do have a bug where the tech assimilator keeps researching the same weapon over and over.

I did read something on MSFC about an updated version of the upgrade project. Are you working on an update? Or is someone else working on it?
posted on February 6th, 2024, 4:33 am
Glad you got some help with the mod. Sorry for not seeing this for the longest time. I never finished an updated version I was going to release in 2019 then again in 2022. It's almost ready and I have been getting the itch to mod some more so may start working on it?

I basically just rebuilt it from the ground up. I also have a stock A2 version not for Fleet Ops I was going to release beside it so we'll see.

About the tech assimilator, are you sure it's that station? That station assimilates special weapons for the cube to utilize and doesn't research. Just wanted to clarify your words so we're on the same page. Does this happen when you are the Borg or then the AI is?
posted on February 7th, 2024, 3:33 am
Yes its the tech assimilator. I noticed it on one of the Borg campaign missions but I haven't tested it in instant action.
posted on February 7th, 2024, 4:19 am
Hmm. I may have to fire up the game to take a look.

Also, to clarify, you mentioned earlier the newdefault.aip file being replaced with a stock version which solved your issue however, I never edited that file in my mod so was just curious. Sorry If I'm jumping around :)
posted on February 7th, 2024, 12:42 pm
No problem. I've attached the version of the file that I'm using. You can look at it and see if any changes were made.

Attachments

newdefault.txt
(11.51 KiB) Downloaded 8 times
1, 2, 3
Reply

Who is online

Users browsing this forum: No registered users and 3 guests

cron